<!doctype html>
<html lang="en-US" class="">
<head>
	<meta charset="UTF-8">
		<meta name="viewport" content="width=device-width, initial-scale=1">
		
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<title>Dolphins Owner Responds to Ex-Coach Brian Flores&#8217; NFL Lawsuit &#8211; NECN</title>
<link rel='dns-prefetch' href='//assets.adobedtm.com' />
<link rel='dns-prefetch' href='//ak.sail-horizon.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//z.moatads.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NECN &raquo; Feed" href="https://www.necn.com/?rss=y" />
<link rel='stylesheet' id='all-css-0' href='https://www.necn.com/_static/??-eJylzEtORCEQheEN2VBQdeEyMA5cCRSFEnkYwbj9bmNcgO34/OfTX+8XnmPL2Hq/SpelR+LL2nHXOTS3+r2kz9qy5rU0z97nUAE8CnCxgjmEA4KcWfU61K150H80X9pMsSmCAuQKsjsIEpILQneb8WNXbqLA5CjWGIo2QGFIJ/0bff65KMeGyKVSPEbOHhHJ3G2nNvltqZLdkaw17IyUiODPw/+aT/3ROMITjUO6AqOMmB4=' type='text/css' media='all' />
<script id='ad-layers-dfp-js-extra'>
var adLayersDFP = {"layerDebugLabel":"Current ad layer","consoleDebugLabel":"Switch to Google console","adUnitPrefix":"div-gpt-ad-"};
</script>
<script src='https://www.necn.com/wp-content/plugins/ad-layers-nbc/js/ad-layers-dfp.js?ver=0.0.9' id='ad-layers-dfp-js'></script>
<script id='ad-layers-js-extra'>
var adLayersAdServer = {"jsAPIClass":"AdLayersDFPAPI"};
</script>
<script src='https://www.necn.com/wp-content/plugins/ad-layers-nbc/js/ad-layers.js?ver=0.0.9' id='ad-layers-js'></script>
<script async src='https://assets.adobedtm.com/a2ef59fba8e9/3ba8c6b033ff/launch-6a742ce4ddf5.min.js?ver=1.0.2' id='adobe-launch-js'></script>
<link rel="https://api.w.org/" href="https://www.necn.com/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.necn.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.necn.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.8" />
<link rel="canonical" href="https://www.nbcmiami.com/news/sports/his-allegations-are-false-dolphins-owner-responds-to-flores-lawsuit-against-nfl-alleging-racist-hiring/2679864/" />
<link rel="alternate" type="application/json+oembed" href="https://www.necn.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.necn.com%2Fnews%2Fsports%2Fhis-allegations-are-false-dolphins-owner-responds-to-flores-lawsuit-against-nfl-alleging-racist-hiring%2F2668907%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.necn.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.necn.com%2Fnews%2Fsports%2Fhis-allegations-are-false-dolphins-owner-responds-to-flores-lawsuit-against-nfl-alleging-racist-hiring%2F2668907%2F&#038;format=xml" />
		<style>
		.getty.aligncenter {
			text-align: center;
		}
		.getty.alignleft {
			float: none;
			margin-right: 0;
		}
		.getty.alignleft > div {
			float: left;
			margin-right: 5px;
		}
		.getty.alignright {
			float: none;
			margin-left: 0;
		}
		.getty.alignright > div {
			float: right;
			margin-left: 5px;
		}
		</style>
		<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">
	.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%), url('https://media.necn.com/2019/09/OTT-NECN.png?resize=1440%2C415&quality=85&strip=all'); }
</style>
<link rel="preload" href="https://www.necn.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Black.woff2" as="font" crossorigin /><link rel="preload" href="https://www.necn.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Bold.woff2" as="font" crossorigin /><link rel="preload" href="https://www.necn.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Medium.woff2" as="font" crossorigin /><link rel="preload" href="https://www.necn.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Light.woff2" as="font" crossorigin /><link rel="preload" href="https://www.necn.com/wp-content/themes/nbc-station/client/build/media/Roboto-Flex.woff2" as="font" crossorigin /><script>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</script><meta property="og:site_name" content="NECN" /><meta name="google-site-verification" content="E-egfefm-gv7oaXIe_jmNFN6dmiCZmu4-1sgCkoQTV8" /><meta property="fb:app_id" content="424638114340719" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@NECN" /><meta name="twitter:creator" content="@NECN" /><meta property="og:type" content="article" /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta name="article:publisher" content="http://www.facebook.com/necntv" /><meta name="description" content="The owner of the Miami Dolphins is breaking his silence after the team&#039;s former head coach filed a lawsuit against the NFL over alleged racist hiring practices." /><meta property="og:description" content="Stephen Ross released a statement early Thursday morning, calling the allegations made by Brian Flores “false, malicious and defamatory.”" /><meta name="twitter:description" content="Stephen Ross released a statement early Thursday morning, calling the allegations made by Brian Flores “false, malicious and defamatory.”" /><meta property="og:title" content="‘His Allegations Are False&#039;: Dolphins Owner Responds to Flores&#039; Lawsuit Against NFL" /><meta name="twitter:title" content="‘His Allegations Are False&#039;: Dolphins Owner Responds to Flores&#039; Lawsuit Against NFL" /><meta name="keywords" content="Brian Flores, Miami Dolphins, NFL, Stephen Ross" /><meta property="og:url" content="https://www.necn.com/news/sports/his-allegations-are-false-dolphins-owner-responds-to-flores-lawsuit-against-nfl-alleging-racist-hiring/2668907/" /><meta name="twitter:url" content="https://www.necn.com/news/sports/his-allegations-are-false-dolphins-owner-responds-to-flores-lawsuit-against-nfl-alleging-racist-hiring/2668907/" /><meta name="sailthru.title" content="Dolphins Owner Responds to Ex-Coach Brian Flores&#039; NFL Lawsuit" /><meta name="sailthru.description" content="The owner of the Miami Dolphins is breaking his silence after the team&#039;s former head coach filed a lawsuit against the NFL over alleged racist hiring practices." /><meta name="sailthru.tags" content="Brian Flores, Miami Dolphins, NFL, Stephen Ross" /><meta name="sailthru.tags" content="Brian Flores, Miami Dolphins, NFL, Stephen Ross" /><meta name="sailthru.type" content="article" /><meta name="sailthru.date" content="2022-02-03T04:46:42+00:00" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:image" content="https://media.necn.com/2022/02/GettyImages-1238125708.jpg?quality=85&#038;strip=all&#038;fit=1200%2C675" /><meta name="twitter:image" content="https://media.necn.com/2022/02/GettyImages-1238125708.jpg?quality=85&#038;strip=all&#038;fit=1200%2C675" /><meta name="taboola_lead" content="video" /><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":"https:\/\/www.necn.com\/news\/sports\/his-allegations-are-false-dolphins-owner-responds-to-flores-lawsuit-against-nfl-alleging-racist-hiring\/2668907\/","headline":"\u2018His Allegations Are False': Dolphins Owner Responds to Flores' Lawsuit Against NFL","datePublished":"2022-02-03T04:46:42","dateModified":"2022-02-03T05:45:38","description":"The owner of the Miami Dolphins is breaking his silence after the team's former head coach filed a lawsuit against the NFL over alleged racist hiring practices.","speakable":{"@type":"SpeakableSpecification","cssSelector":[".article-headline",".article-subtitle"]},"keywords":"Brian Flores, Miami Dolphins, NFL, Stephen Ross","publisher":{"@type":"Organization","name":"NECN","logo":{"@type":"ImageObject","height":60,"url":"https:\/\/media.necn.com\/wp-content\/uploads\/2019\/09\/light_amp_necn.png","width":160}},"image":{"@type":"ImageObject","height":478,"url":"https:\/\/media.necn.com\/2022\/02\/GettyImages-1238125708.jpg?quality=85&strip=all&resize=850%2C478","width":850},"video":{"@type":"VideoObject","contentUrl":"https:\/\/www.necn.com\/news\/sports\/his-allegations-are-false-dolphins-owner-responds-to-flores-lawsuit-against-nfl-alleging-racist-hiring\/2668907\/","description":"Stephen Ross released a statement early Thursday morning, calling the allegations made by Brian Flores &#8220;false, malicious and defamatory.&#8221;","duration":"PT02M03S","name":"\u2018His Allegations Are False': Dolphins Owner Responds to Flores' Lawsuit Against NFL","thumbnailUrl":"https:\/\/media.necn.com\/2022\/02\/GettyImages-1238125708.jpg?quality=85&strip=all&resize=850%2C478","uploadDate":"2022-02-03T04:46:42"},"author":{"@type":"Person","name":"NBC 6,The Associated Press"}}</script>							<script type='text/javascript'>
				var dfpAdUnits = {};
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
				var gads = document.createElement('script');
				gads.async = true;
				gads.type = 'text/javascript';
				var useSSL = 'https:' == document.location.protocol;
				gads.src = (useSSL ? 'https:' : 'http:') +
				'//www.googletagservices.com/tag/js/gpt.js';
				var node = document.getElementsByTagName('script')[0];
				node.parentNode.insertBefore(gads, node);
				})();
				</script>
												<script type="text/javascript">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</script>
			<link rel="amphtml" href="https://www.necn.com/news/sports/his-allegations-are-false-dolphins-owner-responds-to-flores-lawsuit-against-nfl-alleging-racist-hiring/2668907/?amp"><link rel="icon" href="https://media.necn.com/2019/09/cropped-NECN-1.png?fit=32%2C32&#038;quality=85&#038;strip=all" sizes="32x32" />
<link rel="icon" href="https://media.necn.com/2019/09/cropped-NECN-1.png?fit=192%2C192&#038;quality=85&#038;strip=all" sizes="192x192" />
<link rel="apple-touch-icon" href="https://media.necn.com/2019/09/cropped-NECN-1.png?fit=180%2C180&#038;quality=85&#038;strip=all" />
<meta name="msapplication-TileImage" content="https://media.necn.com/2019/09/cropped-NECN-1.png?fit=270%2C270&#038;quality=85&#038;strip=all" />
</head>

<body class="post-template-default single single-post postid-2668907 single-format-standard station-nbc necn has-featured-image short-hero">
	<div class="leaderboard_ad">
		<div id="div-gpt-ad-topbanner_" class=" gpt-topbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbanner_', format: 'topbanner', targeting: {"slot":"topbanner","pos":"topbanner"} });
			</script><div id="div-gpt-ad-mobiletopbanner_" class=" gpt-mobiletopbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobiletopbanner_', format: 'mobiletopbanner', targeting: {"slot":"mobiletopbanner","pos":"mobiletopbanner"} });
			</script>	</div>
	<div id="page" class="site" data-component="wrapper">
	
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner" data-component="siteHeader">
		<div class="site-header__primary">
		<div class="site-header__wrap">
							<div class="site-header__logo">
					<a href="https://www.necn.com/">
						<img src="https://media.necn.com/2021/04/NECN.png?fit=375%2C120&#038;quality=85&#038;strip=all&#038;w=125&#038;h=40" srcset="https://media.necn.com/2021/04/NECN.png?fit=375%2C120&amp;quality=85&amp;strip=all&amp;w=125&amp;h=40 1x, https://media.necn.com/2021/04/NECN.png?fit=375%2C120&amp;quality=85&amp;strip=all&amp;w=250&amp;h=80 2x, https://media.necn.com/2021/04/NECN.png?fit=375%2C120&amp;quality=85&amp;strip=all&amp;w=375&amp;h=120 3x" alt="NECN" height="40" width="125" />					</a>
				</div>
						<div class="site-header__nav-search">
				<div class="site-header__nav-main">
					<button class="site-header__nav-main-toggle">
						<span class="site-header__nav-main-toggle-text">Main Navigation</span>
					</button>
				</div>
				<div class="site-header__search" data-component="headerSearch">
					<button class="site-header__search-toggle">
						<span class="site-header__search-toggle-text">Search</span>
					</button>
					<div class="site-header__search-form">
						
<form class="search-form" role="search" method="get" action="https://www.necn.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
					</div>
				</div>
			</div>
			<div class="site-header__animated-section">
				<nav class="site-header__nav-sections">
					<div class="menu-lower-flyout-menu-container"><nav id="primary-menu" class="menu"><a data-lid="Weather" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/weather/">Weather</a></li>
<a data-lid="Investigations" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/investigations/">Investigations</a></li>
<a data-lid="Videos" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/videos/">Videos</a></li>
<a data-lid="Entertainment" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/entertainment/">Entertainment</a></li>
<a data-lid="Politics" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/politics/">Politics</a></li>
<a data-lid="Business" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/business/">Business</a></li>
<a data-lid="Newsletters" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="https://www.necn.com/newsletters/">Newsletters</a></li>
</nav></div>				</nav>
				<div class="site-header__weather-tv">
					<div
						class="site-header__local-weather"
						data-react-component="NBCWeather"
						data-view="conditions"
					>
					</div>
										<a class="site-header__live-tv" href="https://www.necn.com/live">Live TV</a>
									</div>
				<button class="site-header__mobile-share-toggle">
					<span class="text-share">Share</span>
					<span class="text-close">Close</span>
				</button>
			</div>
		</div> <!-- site-header__wrap -->
	</div> <!-- site-header__primary -->
	<div class="site-header__secondary">
		<div class="site-header__wrap">
							<div class="site-header__trending">
					<span class="site-header__trending-label">Trending</span>
											<nav class="site-header__trending-nav">
												<a data-lid="Tom Brady Retires" data-lpos="trending-stories-module" href="https://www.necn.com/tag/tom-brady/" class="site-header__trending-nav-item">Tom Brady Retires</a>
					<a data-lid="Winter Olympics" data-lpos="trending-stories-module" href="https://www.necn.com/news/sports/beijing-winter-olympics/" class="site-header__trending-nav-item">Winter Olympics</a>
					<a data-lid="Winter Olympics Newsletter" data-lpos="trending-stories-module" href="https://www.necn.com/newsletters/?_osource=ed_npd_nbc_nat_ot_newltrtrending" class="site-header__trending-nav-item">Winter Olympics Newsletter</a>
					<a data-lid="Celebrating Black History" data-lpos="trending-stories-module" href="https://www.necn.com/news/local/celebrating-black-history/" class="site-header__trending-nav-item">Celebrating Black History</a>
					<a data-lid="RealiTea With Derek Z" data-lpos="trending-stories-module" href="https://www.necn.com/realitea-with-derek-z/" class="site-header__trending-nav-item">RealiTea With Derek Z</a>
					<a data-lid="Mom 2 Mom" data-lpos="trending-stories-module" href="https://www.necn.com/mom-2-mom/" class="site-header__trending-nav-item">Mom 2 Mom</a>
					<a data-lid="Chef&#039;s Pantry" data-lpos="trending-stories-module" href="/chefs-pantry/" class="site-header__trending-nav-item">Chef&#039;s Pantry</a>
					<a data-lid="Morning Chat" data-lpos="trending-stories-module" href="https://www.necn.com/morning-chat/" class="site-header__trending-nav-item">Morning Chat</a>
					<a data-lid="On Her Mark" data-lpos="trending-stories-module" href="https://www.necn.com/entertainment/on-her-mark/" class="site-header__trending-nav-item">On Her Mark</a>
					<a data-lid="Bundle Up New England" data-lpos="trending-stories-module" href="https://www.necn.com/news/national-international/how-to-donate-to-the-bundle-up-new-england-clothing-drive/2616081/" class="site-header__trending-nav-item">Bundle Up New England</a>
		
							</nav>
										<div class="site-header__trending-toggle">
						<button class="trending-toggle"><span class="screen-reader-text">Expand</span></button>
					</div>
				</div>

				
<div class="site-header__alerts">
	<div
		class="site-header__weather with-divider"
		data-react-component="NBCWeather"
		data-view="alerts"
		data-alert-singular="Weather Alert"
		data-alert-plural="Weather Alerts"
		data-zip-code="2201">
	</div>
			<a
			href="https://www.necn.com/weather/school-closings/"
			class="site-header__alerts-item site-header__alerts-item--general"
		>
			1 School Closing		</a>
	</div> <!-- site-header__wrap -->
					</div> <!-- site-header__secondary -->
	</div>
</header>
	<div id="content" class="site-content " data-component="formsContainer">
		<div id="primary" class="content-area">
			<main id="main" class="site-main">
				<article id="post-2668907" data-component="article">

	<div
			id="template-hero"
		class="template-hero "
		data-component="templateHero"
	>
			<div class="hero-background"></div>
	
	
	
					
	
	
	
	
	
	
	</div>
		<div class="section-content--header below-hero">
		<div class="article-eyebrow__container">
	<div class="article-eyebrow__wrap">
									<a class="article-eyebrow" href="https://www.necn.com/tag/nfl/">NFL</a>						</div>
	</div>
<div class="article-header--wrap ">
	<h1 class="article-headline">
		‘His Allegations Are False': Dolphins Owner Responds to Flores' Lawsuit Against NFL	</h1>
			<h2 class="article-subtitle">
			Stephen Ross said he welcomes an investigation by the NFL into allegations he offered Brian Flores $100,000 for each loss during the 2019 season to "tank" for a better draft pick		</h2>
				
<div class="article-meta" data-component="articleMeta">
	<h4 class="article-byline">
					By NBC 6 and <a href="https://www.necn.com?s=Author%3A%20%22The%20Associated%20Press%22">The Associated Press</a>							<span class="meta-dot">&bull;</span>
					
									<span class="time-wrap">
					<time class="entry-date published" datetime="2022-02-03T09:46:42-05:00">Published 60 mins ago</time>						<span class="meta-dot">&bull;</span>
					<time class="entry-date updated" datetime="2022-02-03T05:45:38-05:00">Updated 1 min ago</time>				</span>
						</h4>
	<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.necn.com%2Fnews%2Fsports%2Fhis-allegations-are-false-dolphins-owner-responds-to-flores-lawsuit-against-nfl-alleging-racist-hiring%2F2668907%2F&#038;%E2%80%98His%20Allegations%20Are%20False%27%3A%20Dolphins%20Owner%20Responds%20to%20Flores%27%20Lawsuit%20Against%20NFL?_osource=db_npd_nbc_necn_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=%E2%80%98His%20Allegations%20Are%20False%27%3A%20Dolphins%20Owner%20Responds%20to%20Flores%27%20Lawsuit%20Against%20NFL&#038;url=https%3A%2F%2Fwww.necn.com%2Fnews%2Fsports%2Fhis-allegations-are-false-dolphins-owner-responds-to-flores-lawsuit-against-nfl-alleging-racist-hiring%2F2668907%2F?_osource=db_npd_nbc_necn_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=%E2%80%98His%20Allegations%20Are%20False%27%3A%20Dolphins%20Owner%20Responds%20to%20Flores%27%20Lawsuit%20Against%20NFL%0D%0A%0D%0Ahttps%3A%2F%2Fwww.necn.com%2Fnews%2Fsports%2Fhis-allegations-are-false-dolphins-owner-responds-to-flores-lawsuit-against-nfl-alleging-racist-hiring%2F2668907%2F?_osource=db_npd_nbc_necn_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
	</div>
</div>
		</div>
	</div>
		<div class="section-content--full below-hero">
		<div class="section-content--primary">
			<div class="article-content--wrap">
				<div class="video-flyout" data-component="videoFlyout">
	<figure class="article-featured-media video-lead">
		<div
			data-react-component="VideoPlayer"
		data-meta="{&quot;amp_status&quot;:&quot;&quot;,&quot;spay_email&quot;:&quot;&quot;,&quot;syndicated_id&quot;:&quot;&quot;,&quot;should_nationalize&quot;:false,&quot;nbc_first_published_date&quot;:&quot;&quot;,&quot;nbc_prevent_modified_update&quot;:false,&quot;nbc_linkout_title&quot;:&quot;&quot;,&quot;nbc_linkout_url&quot;:&quot;&quot;,&quot;nbc_linkout_excerpt_link&quot;:&quot;&quot;,&quot;nbc_primary_category_id&quot;:0,&quot;nbc_primary_tag_id&quot;:0,&quot;nbc_social_page_title&quot;:&quot;&quot;,&quot;nbc_page_title&quot;:&quot;&quot;,&quot;nbc_seo_description&quot;:&quot;&quot;,&quot;nbc_social_description&quot;:&quot;&quot;,&quot;nbc_national_headline&quot;:&quot;&quot;,&quot;entities&quot;:&quot;&quot;,&quot;nbc_canonical_market&quot;:&quot;&quot;,&quot;nbc_canonical_url&quot;:&quot;&quot;,&quot;nbc_hide_from_recirculation&quot;:&quot;&quot;,&quot;nbc_hide_from_search&quot;:&quot;&quot;,&quot;nbc_syndication_category&quot;:&quot;&quot;,&quot;nbc_national_collections&quot;:[],&quot;nopreroll&quot;:false,&quot;video_copyright&quot;:&quot;NBC Universal, Inc.&quot;,&quot;sst_source_id&quot;:&quot;&quot;,&quot;nbc_disable_legacy_embeds&quot;:false,&quot;nbc_feed_loader_prevent_updates&quot;:&quot;&quot;,&quot;post_video_prompt&quot;:&quot;&quot;,&quot;nbc_checkout_experience_enabled&quot;:false,&quot;desktopFlashPid&quot;:&quot;&quot;,&quot;mpx_dfxp_url&quot;:&quot;https:\/\/media.nbcmiami.com\/assets\/video\/NBCU_LM_VMS_-_WTVJ\/977\/707\/14628496690.dfxp&quot;,&quot;mp4_url&quot;:&quot;http:\/\/nbclim-download.edgesuite.net\/Prod\/NBCU_LM_VMS_-_WTVJ\/977\/707\/14628496690-1080pnbcstations.mp4&quot;,&quot;mpx_download_pid&quot;:&quot;GWKtOK64ztYi&quot;,&quot;mpx_download_pid_high&quot;:&quot;b_Poql8vRRxY&quot;,&quot;mpx_high_id&quot;:&quot;&quot;,&quot;mpx_high_url&quot;:&quot;&quot;,&quot;mpx_is_livestream&quot;:&quot;&quot;,&quot;mpx_m3upid&quot;:&quot;&quot;,&quot;mpx_pid&quot;:&quot;btt339Ej9zuX&quot;,&quot;mpx_thumbnail_url&quot;:&quot;https:\/\/media.necn.com\/2022\/02\/14628496690-1080pnbcstations.jpg?quality=85&amp;strip=all&amp;resize=850%2C478&quot;,&quot;pid_streaming_web_high&quot;:&quot;eMo7Isls1l9z&quot;,&quot;pid_streaming_web_medium&quot;:&quot;2OMLAGq_iT1d&quot;,&quot;subtitle&quot;:&quot;&quot;,&quot;dfxp_url&quot;:&quot;&quot;,&quot;video_call_letter&quot;:&quot;WTVJ&quot;,&quot;video_captions&quot;:&quot;NEED THEM. HOARSE YOUR 7-DAY FORECAST. WE STAY MILD, A WEAK COLD FRONT HITS EARLY NEXT WEEK. I BLAME THAT ON THE SYSTEM. I BLAME THAT ON THE SYSTEM. NEVER MY FAULT. &gt;&gt; I WAS HUMILIATED. &gt;&gt; I WAS HUMILIATED. THERE WAS ANGER, DISAPPOINTMENT, DISBELIEF. &gt;&gt; ALL RIGHT. THIS STORY MAKING HEADLINES, NOT JUST HERE LOCALLY, FORMER MIAMI DOLPHINS HEAD FOOTBALL COACH BRIAN FLORES SUING THE NFL AND THREE TEAMS, INCLUDING HIS FORMER TEAM, THE MIAMI DOLPHINS. COACH FLORES NOW SPEAKING OUT ON WHAT HE SAYS ARE RACIST HIRING PRACTICES IN THE NFL. PRACTICES IN THE NFL. THIS MORNING, WE ARE ALSO HEARING FROM DOLPHINS\u2019 OWNER STEPHEN ROSS, WHO IS BREAKING STEPHEN ROSS, WHO IS BREAKING HIS SILENCE ABOUT THIS LAWSUIT. &gt;&gt; JULIA BAGG JOINS US OUTSIDE HARD ROCK STADIUM. WHAT IS HE SAYING, JULIA? &gt;&gt; Reporter: YEAH, THIS MORNING, HE IS SAYING HE CANNOT LET THESE ALLEGATIONS STAND, THAT PART OF WHAT HE SAID IN A STATEMENT, WHAT HE SAID IN A STATEMENT, RELEASED FROM DOLPHINS OWNER STEPHEN ROSS. HE SAID ALSO THE TRUTH MUST BE KNOWN. THE MIAMI DOLPHINS FIRED BRIAN FLORES AFTER BACK-TO-BACK WINNING SEASONS. FLORES AND HIS ATTORNEYS HAVE FILED A CLASS ACTION LAWSUIT AGAINST THE NFL AND SEVERAL TEAMS ALLEGING DISCRIMINATION TEAMS ALLEGING DISCRIMINATION AGAINST BLACK COACHES. FLORES ACCUSES ROSS OF OFFERING TO PAY HIM $100,000 PER LOSS IN TO PAY HIM $100,000 PER LOSS IN 20 THEN TO IMPROVE THE TEAM\u2019S DRAFT POSITION. FLORES SAYS HE KNOWS HE IS RISKING HIS CAREER. &gt;&gt; YOU CAN MAKE CHANGES TO THIS SYSTEM. GIVE MORE OPPORTUNITIES TO BLACK AND MINORITY COACHES, REAL OPPORTUNITY. I THINK IT WILL BE WORTH IT. &gt;&gt; BACK TO THAT BRANDS NEW STATEMENT THIS MORNING. STATEMENT THIS MORNING. ROSS ALSO SAYING, IN PART, I AM A MAN OF HONOR AND INTEGRITY. HE CALLS FLORES\u2019 ACCUSATIONS, FALSE, MALICIOUS AND DEFAMATORY.&quot;,&quot;video_id&quot;:&quot;1999257667708_269&quot;,&quot;video_length&quot;:&quot;123390&quot;,&quot;video_provider&quot;:&quot;mpx&quot;,&quot;short_video_excerpt&quot;:&quot;&quot;,&quot;mpx_download_pid_mobile_low&quot;:&quot;EjmPmjP_82NR&quot;,&quot;pid_streaming_web_mobile_low&quot;:&quot;&quot;,&quot;mpx_download_pid_mobile_standard&quot;:&quot;CrakhHB9J7ce&quot;,&quot;pid_streaming_mobile_standard&quot;:&quot;btt339Ej9zuX&quot;,&quot;alleypack_schedule_unpublish&quot;:&quot;&quot;,&quot;feed_remote_id&quot;:&quot;mpx_1999257667708&quot;,&quot;feed_thumbnail_url&quot;:&quot;&quot;}"
	data-livestream="false"
	data-title="Dolphins Owner Speaks Out After Lawsuit From Former Coach"
	data-vidcid="1:10:2679896"
	data-vidurl="https://www.nbcmiami.com/news/sports/dolphins-owner-speaks-out-after-lawsuit-from-former-coach/2679896/"
			data-islead="true"
		data-catnames="{&quot;5856&quot;:&quot;On Air&quot;,&quot;5857&quot;:&quot;As Seen On&quot;,&quot;445300&quot;:&quot;News&quot;,&quot;434&quot;:&quot;Sports&quot;}"
	data-tagnames="{&quot;3030&quot;:&quot;Brian Flores&quot;,&quot;1782&quot;:&quot;Miami Dolphins&quot;,&quot;1878&quot;:&quot;NFL&quot;,&quot;7804&quot;:&quot;Stephen Ross&quot;}"
	data-customdata="{&quot;ContentPartner&quot;:&quot;None&quot;,&quot;Source&quot;:&quot;WEBFM&quot;,&quot;SyndicationAllowed&quot;:&quot;true&quot;,&quot;mSNVideoCategories&quot;:&quot;MSN Video v4 Connector-most watched news&quot;,&quot;mSNVideoContentSupplierID&quot;:&quot;NBC_Local&quot;,&quot;mSNVideoCountry&quot;:&quot;us&quot;,&quot;subtitle&quot;:&quot;nosubtitle&quot;,&quot;uploadedByTeam&quot;:&quot;1&quot;,&quot;youtubeChannel&quot;:&quot;None&quot;}"
			data-autoplay="true"
				data-cplay="true"
	></div>
			<figcaption>
									<cite>NBC Universal, Inc.</cite>
				
															<div
							class="caption"
							data-react-component="NBCTruncate"
							data-maxlines="2"
							data-maxlinesmobile="4"
							data-readmore="Read more"
							data-text="Brian Flores says his lawsuit against the NFL over alleged racist hiring practices will continue even if he becomes a head coach again this offseason. NBC 6 South Florida&#039;s Ruthie Polinsky and Steve Litz report"
							data-ellipsis="false">
						</div>
												</figcaption>
						<button class="video-flyout__dismiss"><span class="icon icon-times"></span></button>
			</figure>
</div>
				<div class="article-content rich-text">
					
					
<p>The owner of the Miami Dolphins is breaking his silence after the team's former head coach filed a lawsuit against the NFL over alleged racist hiring practices.</p>

<p>Stephen Ross released a statement early Thursday morning, calling the allegations made by Brian Flores "false, malicious and defamatory."</p>

<p>“With regards to the&nbsp;allegations&nbsp;being made by Brian Flores,&nbsp;I am a man&nbsp;of&nbsp;honor and integrity and cannot let them stand without responding. I take great personal exception to these malicious attacks, and the truth must be known," Ross said in a statement.</p>

<p>Flores says his lawsuit against the NFL will continue even if he becomes a head coach again this offseason.</p>

<p>“This is about changing the hiring practices in the National Football League, and that's what this lawsuit is about,” <a rel="noreferrer noopener" href="/news/sports/we-knew-it-was-a-setup-brian-flores-speaks-after-filing-suit-against-nfl-over-racist-hiring/" target="_blank">Flores said Wednesday on CNN</a>. “I want to coach football; that’s what I’m called to do.”</p>
<div data-react-component="VideoPlayer" data-meta="{&quot;amp_status&quot;:&quot;&quot;,&quot;spay_email&quot;:&quot;&quot;,&quot;syndicated_id&quot;:&quot;&quot;,&quot;should_nationalize&quot;:false,&quot;nbc_first_published_date&quot;:&quot;&quot;,&quot;nbc_prevent_modified_update&quot;:false,&quot;nbc_linkout_title&quot;:&quot;&quot;,&quot;nbc_linkout_url&quot;:&quot;&quot;,&quot;nbc_linkout_excerpt_link&quot;:&quot;&quot;,&quot;nbc_primary_category_id&quot;:0,&quot;nbc_primary_tag_id&quot;:0,&quot;nbc_social_page_title&quot;:&quot;&quot;,&quot;nbc_page_title&quot;:&quot;&quot;,&quot;nbc_seo_description&quot;:&quot;&quot;,&quot;nbc_social_description&quot;:&quot;&quot;,&quot;nbc_national_headline&quot;:&quot;&quot;,&quot;entities&quot;:&quot;&quot;,&quot;nbc_canonical_market&quot;:&quot;&quot;,&quot;nbc_canonical_url&quot;:&quot;&quot;,&quot;nbc_hide_from_recirculation&quot;:&quot;&quot;,&quot;nbc_hide_from_search&quot;:&quot;&quot;,&quot;nbc_syndication_category&quot;:&quot;&quot;,&quot;nbc_national_collections&quot;:[],&quot;nopreroll&quot;:false,&quot;video_copyright&quot;:&quot;NBC Universal, Inc.&quot;,&quot;sst_source_id&quot;:&quot;&quot;,&quot;nbc_disable_legacy_embeds&quot;:false,&quot;nbc_feed_loader_prevent_updates&quot;:&quot;&quot;,&quot;post_video_prompt&quot;:&quot;&quot;,&quot;nbc_checkout_experience_enabled&quot;:false,&quot;desktopFlashPid&quot;:&quot;&quot;,&quot;mpx_dfxp_url&quot;:&quot;https:\/\/media.nbcmiami.com\/assets\/video\/NBCU_LM_VMS_-_WTVJ\/768\/223\/14619879220.dfxp&quot;,&quot;mp4_url&quot;:&quot;http:\/\/nbclim-download.edgesuite.net\/Prod\/NBCU_LM_VMS_-_WTVJ\/768\/223\/14619879220-1080pnbcstations.mp4&quot;,&quot;mpx_download_pid&quot;:&quot;XLXW401_OoCl&quot;,&quot;mpx_download_pid_high&quot;:&quot;2UDXfp5ssb31&quot;,&quot;mpx_high_id&quot;:&quot;&quot;,&quot;mpx_high_url&quot;:&quot;&quot;,&quot;mpx_is_livestream&quot;:&quot;&quot;,&quot;mpx_m3upid&quot;:&quot;&quot;,&quot;mpx_pid&quot;:&quot;iYdLiGAIDNt7&quot;,&quot;mpx_thumbnail_url&quot;:&quot;https:\/\/media.necn.com\/2022\/02\/14619879220-1080pnbcstations.jpg?quality=85&amp;strip=all&amp;resize=850%2C478&quot;,&quot;pid_streaming_web_high&quot;:&quot;jqbdec83CVoX&quot;,&quot;pid_streaming_web_medium&quot;:&quot;2cKPERLIcwFK&quot;,&quot;subtitle&quot;:&quot;&quot;,&quot;dfxp_url&quot;:&quot;&quot;,&quot;video_call_letter&quot;:&quot;WTVJ&quot;,&quot;video_captions&quot;:&quot;&gt;&gt; Announcer: LIVE, NBC NEWS AT 6:00 STARTS NOW. &gt;&gt; I WAS HUMILIATED. IT WAS ANGER, THERE WAS IT WAS ANGER, THERE WAS DISAPPOINTMENT, DISBELIEF. &gt;&gt; FORMER MIAMI DOLPHINS HEAD COACH BRIAN FLORES IS SUING THE COACH BRIAN FLORES IS SUING THE NFL AND THREE FORMER TEAMS INCLUDING THE DOLPHINS. FLORES NOW SPEAKING OUT ON WHAT HE SAID ARE RACIST HIRING PRACTICES. HELLO, AND THANKS FOR JOINING US, I\u2019M JACKIE NESPRAL. &gt;&gt; AND I\u2019M JAWAN STRADER. AND THEY ARE MAKING OTHER SERIOUS ALLEGATIONS AGAINST STEVEN ROSS. &gt;&gt; TONIGHT WE HAVE TEAM COVERAGE &gt;&gt; TONIGHT WE HAVE TEAM COVERAGE BUT WE BEGIN WITH NBC 6 SPORT ANCHOR RUTHIE WITH MORE. ANCHOR RUTHIE WITH MORE. &gt;&gt; BRIAN FLORES DOING THE MEDIA ROUNDS WITH HIS ATTORNEYS TO SPEAK OUT. THE FORMER DOLPHINS COACH IS ALLEGING RACISM IN THE LEAGUE\u2019S HIRING AND FIRING PRACTICES THAT HE\u2019S EXPERIENCED AND SEEN FOR YEARS. HE SAID THE TIPPING POINT WAS WHEN HE RECEIVED THE NOW WHEN HE RECEIVED THE NOW INFAMOUS TEXT FROM BILL BELICHICK CONGRATULATING THE WRONG BRIAN ON GETTING THE GIANTS JOB. HE WAS STILL WAITING TO HAVE HIS HE WAS STILL WAITING TO HAVE HIS SECOND INTERVIEW WHICH HE ATTENDED AS AN ALLEGED SHAM INTERVIEW. NOW HE WANTS TO MAKE CHANGE IN A LEAGUE DOMINATED BY BLACK PLAYERS BUT SEEING ABSENCE OF BLACK LEADERSHIP. DAVID GOTTLIEB IS A PARTNER IN THE FIRM REPRESENTING FLORES. I SPOKE WITH HIM TODAY. I SPOKE WITH HIM TODAY. &gt;&gt; NFL OFFICIALS MADE PUBLIC STATEMENTS THAT ARE CONTRARY TO WHAT THE NFL SAID YESTERDAY. WHAT THE NFL SAID YESTERDAY. SO TROY VINCENT, WHO IS THE VP OF OPERATIONS SAID, I\u2019M GOING TO GIVE YOU A QUOTE HERE, THERE IS A DOUBLE STANDARD, I DON\u2019T THINK THAT IS SOMETHING THAT WE SHOULD SHY AWAY FROM. BUT THAT IS ALL PART OF SOME OF BUT THAT IS ALL PART OF SOME OF THE THINGS THAT WE NEED TO FIX IN THIS SYSTEM. JOHN BEING THE NFL CHIEF JOHN BEING THE NFL CHIEF DIVERSITY INVESTOR SAID ANY CRITICISM FROM THE GM AND HEAD COACH POSITIONS WE DESERVE. WE SEE THAT WE\u2019RE NOT WHERE WE WE SEE THAT WE\u2019RE NOT WHERE WE WANT TO BE. WE HAVE TO DO MUCH BETTER. SO THE NFL HAS ADMITTED THAT THERE IS A PROBLEM. AND EVERYBODY KNOWS THERE IS A PROBLEM. THAT IS NOT NEWS. THAT IS -- THE NEWS IS THAT BRIAN FLORES STEPPED UP AND FILED THIS CASE. &gt;&gt; GOTTLIEB TELLING ME THEY WERE &gt;&gt; GOTTLIEB TELLING ME THEY WERE EXTREMELY DISAPPOINTED IN THE NFL STATEMENT LAST NIGHT. THIS IS A CLASS-ACTION LAWSUIT THIS IS A CLASS-ACTION LAWSUIT WHICH MEANS OTHERS ARE LIKELY GOING TO JOIN THE CASE AGAINST THE HIRING PRACTICES. THE ATTORNEYS ARE ALSO SAYING THERE IS CORROBORATING EVIDENCE AGAINST THE DOLPHINS AND THE LEAGUE. BRIAN FLORES IS SPEAKING WITH NBC \&quot;NIGHTLY NEWS\&quot; RIGHT AFTER THE NEWS AT 6:00. THE NEWS AT 6:00. &gt;&gt; AND OUR TEAM COVERAGE CONTINUES WITH STEVE LITZ AND THE NEW ALLEGATIONS AGAINST THE DOLPHINS\u2019 OWNER. STEVE? &gt;&gt; Reporter: AND HI, JACKIE. IT IS THE OFF-SEASON FOR THE MIAMI DOLPHINS BUT THE TEAM AND ITS COACH ARE MAKING NATIONAL HEADLINES. THE ATTORNEY YOU HEARD FROM FLORES IS SPEAKING OUT, TALKING ABOUT THE COACH\u2019S CLAIMS WHILE ABOUT THE COACH\u2019S CLAIMS WHILE THE TEAM SAID THEY ARE JUST NOT. BRIAN FLORES FILING A LAWSUIT AGAINST THE DOLPHINS YESTERDAY AGAINST THE DOLPHINS YESTERDAY AND BOLSTERING HIS CLAIMS TODAY. &gt;&gt; AND HE OFFERS TO PAID $100,000 FOR EACH GAME YOU LOST. &gt;&gt; Reporter: APPEARING ON NETWORK NEWS AND SPORTS PROGRAMS SAYING HE WAS MISTREATED. MAKE A HEFTY CLAIM AGAINST STEVEN ROSS THAT HE TOLD MR. STEVEN ROSS THAT HE TOLD MR. FLORES THAT HE WOULD PAY HIM $100,000 FOR EVERY LOSS AND THE GENERAL MANAGER CHRIS GRIER TOLD MR. FLORES THAT STEVE WAS MAD MR. FLORES THAT STEVE WAS MAD THAT MR. FLORES\u2019S SUCCESS IN WINNING GAMES THAT YEAR WAS COMPROMISING THE TEAM\u2019S DRAFT POSITION. DAVID GOTTLIEB IS ONE EVER HIS ATTORNEYS. &gt;&gt; HE WAS ASKED TO DO UNETHICAL THINGS WITH RESPECT TO TAMPERING, WITH RESPECT TO TANKING GAMES, HE WASN\u2019T GIVEN SUPPORT AND WHEN HE PUSHED BACK SUPPORT AND WHEN HE PUSHED BACK ON THAT, HE WAS LABELLED AS ABRASIVE AND UNCOOPERATIVE AND THEN HE WAS ULTIMATELY THEN HE WAS ULTIMATELY TERMINATED. &gt;&gt; Reporter: ROSS DENIES ALL OF THE ALLEGATIONS MADE BY FLORES. MEANTIME THE SUIT IS DOMINATING MIAMI SPORTS TALK AIRWAVES. &gt;&gt; I BELIEVE THIS IS THE CURSE OF DON SHULA AND I\u2019M REALLY DISGUSTED. &gt;&gt; WQAM FIELDED CALLS ALL DAY ON &gt;&gt; WQAM FIELDED CALLS ALL DAY ON THE TOPIC AND HAS THIS TAKE. &gt;&gt; MAYBE THE NFL PENALIZED THE DOLPHINS BECAUSE OF WHAT HAPPENED THERE, MAYBE THEY\u2019RE TAKEN AWAY DRAFT PICKS NOW THAT DOLPHINS FANS ARE LEFT HOLDING THE BAG BUT WE SHOULDN\u2019T BE PUNISHED FOR THAT. &gt;&gt; Reporter: HE SAID TEAMS &gt;&gt; Reporter: HE SAID TEAMS TANKING, INTENTIONALLY LOSING TO GET A BETTER DRAFT PICK HAPPENS AT THE REQUEST OF OWNERSHIP BUT HE SAID OFFERING MONEY TO A HE SAID OFFERING MONEY TO A COACH TO TANK HIS OWN TEAM IS NOT. RIGHT NOW BRIAN FLORES IS A CANDIDATE FOR SEVERAL OPEN HEAD COACH POSITIONS. AND REMEMBER THAT THE DOLPHINS ARE IN THE MARKET FOR A HEAD COACH AND THAT IS SOMETHING THAT WILL BE HIRED IN THE MIDST OF ALL OF THIS CONTROVERSY. WE\u2019LL KEEP YOU POSTED ON THAT.&quot;,&quot;video_id&quot;:&quot;1999038019832_659&quot;,&quot;video_length&quot;:&quot;284151&quot;,&quot;video_provider&quot;:&quot;mpx&quot;,&quot;short_video_excerpt&quot;:&quot;&quot;,&quot;mpx_download_pid_mobile_low&quot;:&quot;M4aEsKPTxLzy&quot;,&quot;pid_streaming_web_mobile_low&quot;:&quot;&quot;,&quot;mpx_download_pid_mobile_standard&quot;:&quot;9UuCMHO0Ap0n&quot;,&quot;pid_streaming_mobile_standard&quot;:&quot;iYdLiGAIDNt7&quot;,&quot;alleypack_schedule_unpublish&quot;:&quot;&quot;,&quot;feed_remote_id&quot;:&quot;mpx_1999038019832&quot;,&quot;feed_thumbnail_url&quot;:&quot;&quot;}" data-livestream="false" data-title="Brian Flores Speaks Out About Lawsuit Against NFL" data-vidcid="1:10:2679627" data-vidurl="https://www.nbcmiami.com/news/sports/brian-flores-speaks-out-about-lawsuit-against-nfl/2679627/" data-islead="false" data-catnames="{&quot;5856&quot;:&quot;On Air&quot;,&quot;5857&quot;:&quot;As Seen On&quot;,&quot;434&quot;:&quot;Sports&quot;,&quot;445300&quot;:&quot;News&quot;,&quot;3032&quot;:&quot;Miami Dolphins&quot;}" data-tagnames="{&quot;3030&quot;:&quot;Brian Flores&quot;,&quot;1782&quot;:&quot;Miami Dolphins&quot;,&quot;1878&quot;:&quot;NFL&quot;,&quot;7804&quot;:&quot;Stephen Ross&quot;}" data-customdata="{&quot;ContentPartner&quot;:&quot;None&quot;,&quot;Source&quot;:&quot;WEBFM&quot;,&quot;SyndicationAllowed&quot;:&quot;true&quot;,&quot;mSNVideoCategories&quot;:&quot;MSN Video v4 Connector-most watched news&quot;,&quot;mSNVideoContentSupplierID&quot;:&quot;NBC_Local&quot;,&quot;mSNVideoCountry&quot;:&quot;us&quot;,&quot;subtitle&quot;:&quot;nosubtitle&quot;,&quot;uploadedByTeam&quot;:&quot;1&quot;,&quot;youtubeChannel&quot;:&quot;None&quot;}" data-autoplay="false" data-cplay="true"></div>
<div class="video_caption" data-react-component="NBCTruncate" data-maxlines="2" data-maxlinesmobile="4" data-readmore="Read more" data-text="Brian Flores says his lawsuit against the NFL over alleged racist hiring practices will continue even if he becomes a head coach again this offseason. NBC 6&#039;s Ruthie Polinsky and Steve Litz report" data-ellipsis="false">
							Brian Flores says his lawsuit against the NFL over alleged racist hiring practices will continue even if he becomes a head coach again this offseason. NBC 6&#039;s Ruthie Polinsky and Steve Litz report
						</div>
<p>Ross said he welcomes an investigation by the NFL into allegations he offered Flores $100,000 for each loss during the 2019 season to "tank" for a better draft pick.</p>
<div class="mobile-app-promotion">
	
<div class="wp-block-nbc-localized-block">
<blockquote class="featured-text">
	<strong><em>Download our local news and weather app for </em></strong><a href="https://apps.apple.com/us/app/necn/id943970549">iOS</a> <em><strong><em>or</em></strong></em> <a href="https://play.google.com/store/apps/details?id=com.nbcuniversal.droid.necnnews&amp;hl=en_US&amp;gl=US">Android</a> <strong><em>— and the choose the alerts you want.</em></strong></blockquote>
</div>
</div>
<div class="recirc-module">
	<h3 class="recirc__heading">Sports</h3>
	<p class="recirc__subheading">Patriots, Red Sox, Bruins, Celtics and more </p>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="‘Power Played&#039;: Team USA Mixed Curling Slips Late Against Norway, Now 1-2" href="https://www.necn.com/news/sports/beijing-winter-olympics/team-usa-mixed-curling-loses-third-set-to-norway/2668868/">
							<img class="post__image" srcset="https://media.necn.com/2022/02/GettyImages-1368334941.jpg?quality=85&amp;strip=all&amp;resize=200%2C113 200w, https://media.necn.com/2022/02/GettyImages-1368334941.jpg?quality=85&amp;strip=all&amp;resize=400%2C225 400w, https://media.necn.com/2022/02/GettyImages-1368334941.jpg?quality=85&amp;strip=all&amp;resize=600%2C338 600w, " src="https://media.necn.com/2022/02/GettyImages-1368334941.jpg?quality=85&#038;strip=all&#038;resize=600%2C338" alt="" sizes="200px" loading="lazy" />
						</a>

						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="Beijing 2022 Winter Olympics" class="post__tag" href="https://www.necn.com/tag/beijing-2022-winter-olympics/">Beijing 2022 Winter Olympics</a>
																			<span class="post__date post__date--has-category">
								3 hours ago							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="‘Power Played&#039;: Team USA Mixed Curling Slips Late Against Norway, Now 1-2" class="post__title--link" href="https://www.necn.com/news/sports/beijing-winter-olympics/team-usa-mixed-curling-loses-third-set-to-norway/2668868/">
								‘Power Played&#039;: Team USA Mixed Curling Slips Late Against Norway, Now 1-2							</a>
						</h3>
									</div>
			</div>
		</div>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="Snowboarder Jamie Anderson Says Artificial Snow in Beijing Is ‘Bulletproof Ice&#039;" href="https://www.necn.com/news/sports/beijing-winter-olympics/snowboarder-jamie-anderson-says-artificial-snow-in-beijing-is-bulletproof-ice/2668835/">
							<img class="post__image" srcset="https://media.necn.com/2022/02/DIT-OTS-OLY-TOS-AndersonOnSnow-020222-BF.jpg?quality=85&amp;strip=all&amp;resize=200%2C113 200w, https://media.necn.com/2022/02/DIT-OTS-OLY-TOS-AndersonOnSnow-020222-BF.jpg?quality=85&amp;strip=all&amp;resize=400%2C225 400w, https://media.necn.com/2022/02/DIT-OTS-OLY-TOS-AndersonOnSnow-020222-BF.jpg?quality=85&amp;strip=all&amp;resize=600%2C338 600w, " src="https://media.necn.com/2022/02/DIT-OTS-OLY-TOS-AndersonOnSnow-020222-BF.jpg?quality=85&#038;strip=all&#038;resize=600%2C338" alt="" sizes="200px" loading="lazy" />
						</a>

													<span class="format-icon format-icon--video"></span>
						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="Snowboard Slopestyle/Big Air" class="post__tag" href="https://www.necn.com/tag/snowboard-slopestyle-big-air/">Snowboard Slopestyle/Big Air</a>
																			<span class="post__date post__date--has-category">
								6 hours ago							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="Snowboarder Jamie Anderson Says Artificial Snow in Beijing Is ‘Bulletproof Ice&#039;" class="post__title--link" href="https://www.necn.com/news/sports/beijing-winter-olympics/snowboarder-jamie-anderson-says-artificial-snow-in-beijing-is-bulletproof-ice/2668835/">
								Snowboarder Jamie Anderson Says Artificial Snow in Beijing Is ‘Bulletproof Ice&#039;							</a>
						</h3>
									</div>
			</div>
		</div>
	</div>

<p>"I welcome that investigation and I am eager to&nbsp;defend&nbsp;my personal&nbsp;integrity,&nbsp;and the integrity and values of the entire Miami Dolphins organization,&nbsp;from these baseless, unfair and disparaging&nbsp;claims," the statement said.</p>

<p><a href="/news/sports/brian-flores-suing-nfl-giants-over-racism-in-hiring-process/" target="_blank" rel="noreferrer noopener">Flores' lawsuit was filed Tuesday</a> in Manhattan federal court. It is seeking class-action status and unspecified damages from the league, the Miami Dolphins, the Denver Broncos and the New York Giants, along with unidentified individuals.</p>

<p>The NFL, Dolphins, Broncos and Giants have denied Flores' accusations. In its statement, the NFL said it will defend “against these claims, which are without merit.”</p>

<p>Rod Graves, executive director of the Fritz Pollard Alliance and a former general manager in the league, noted Flores’ lawsuit is the latest call to action for the NFL and its team owners.</p>

<p>The Alliance, which fights for equity and inclusion in pro football, is named after a Black player and coach in the 1920s who is in the Pro Football Hall of Fame. It champions diversity in the NFL “through education and providing its members with resources that will help them succeed at every level of the game.”</p>

<p>”Men and women of color in the NFL community have long known that the odds of advancing in the coaching ranks and in the front office are stacked against them," Graves said in a statement. “The Fritz Pollard Alliance supports coach Flores and others in their effort to level the playing field for men and women of color.”</p>

<p><a href="/news/sports/stephon-gilmore-nfl-players-react-to-brian-flores-dolphins-firing/" target="_blank" rel="noreferrer noopener">Flores, 40, was fired last month</a> by Miami after leading the Dolphins to a 24-25 record over three years. They went 9-8 in their second straight winning season, but failed to make the playoffs during his tenure.</p>

<p>The lawsuit alleged that Ross then pressured Flores to recruit a prominent quarterback in violation of the league’s tampering rules. When Flores refused, he was cast as the “angry Black man” who is difficult to work with and was derided until he was fired, the suit said.</p>

<p>Flores said he had conversations with general manager Chris Grier that Ross was upset that Miami was compromising its draft position by winning too many games. Flores said he also talked repeatedly with Ross, who said the team didn't need to win right then and the coach was under contract.</p>

<p>“That’s not something you make up,” Flores said of those conversations.</p>

<p>What drove Flores to file the lawsuit was a string of text messages with New England Patriots coach Bill Belichick three days before his scheduled Giants interview, leading Flores to believe Brian Daboll already had been chosen as the new coach.</p>

<p>“It was humiliating to be quite honest,” Flores said. "There was disbelief, there was anger, there was a wave of emotion for a lot of reasons. I think this is why we filed the lawsuit.”</p>

<p>Since the NFL implemented the Rooney Rule in 2003 to boost hiring of minority coaches, 27 of 127 head coaching jobs have gone to minorities. This year, white men have filled the first four of nine head coaching jobs.</p>

<p>The rule requires teams to interview at least two external minority candidates for general manager/executive of football operations positions, head coach and all coordinator roles. At least one of those interviews must be held in-person for any head coach or general manager opening.</p>

<p>Tony Dungy, a Pro Football Hall of Famer who was head coach of Tampa Bay and Indianapolis, told The Associated Press last month Rooney's goal with the rule was to slow the hiring process down and investigate different candidates instead of simply interviewing a minority candidate before announcing a hire.</p>

<p>“He wanted to create a process to search for candidates, not an interviewing quota,” Dungy said. "My hope would be for owners to spell out very specifically what they’re looking for and then have them really research a variety of people before making a decision.”</p>

<p>Teryl Austin, a senior assistant defensive coach with Pittsburgh with the NFL's lone Black head coach in Mike Tomlin, has been interviewed for 11 head coaching jobs without being hired. He talked to the AP in October about the NFL's hiring pipeline and said the interviews are “invaluable experiences” and that the rule gets Black candidates in front of owners.</p>

<p>Flores’ lawsuit mentions Austin as someone who was “Never Given a Chance” among the coaches who have interviewed for head coaching jobs unsuccessfully.</p>

<p>Yes, Austin could tell when an interview was real or merely scratching the Rooney Rule box.</p>

<p>“I could tell when I was really in it," Austin said. "And so to me, that’s kind of worth it.”</p>

<p>Flores said he understands this lawsuit may keep him from ever coaching again. He's being called the NFL's Rosa Parks in taking on the league's hiring practices, and Flores called that a humbling comparison.</p>

<p>“That gives me more confidence that we made the right decision here and that we need to continue to fight for that change,” Flores said.</p>

									</div>
								<div class="article-footer">
			<div class="article-tags">
	<h4 class="article-tags__heading">This article tagged under:</h4>
	<a class="article-tags__tag" href="https://www.necn.com/tag/nfl/">NFL</a><a class="article-tags__tag" href="https://www.necn.com/tag/miami-dolphins/">Miami Dolphins</a><a class="article-tags__tag" href="https://www.necn.com/tag/stephen-ross/">Stephen Ross</a><a class="article-tags__tag" href="https://www.necn.com/tag/brian-flores/">Brian Flores</a></div>
			<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.necn.com%2Fnews%2Fsports%2Fhis-allegations-are-false-dolphins-owner-responds-to-flores-lawsuit-against-nfl-alleging-racist-hiring%2F2668907%2F&#038;%E2%80%98His%20Allegations%20Are%20False%27%3A%20Dolphins%20Owner%20Responds%20to%20Flores%27%20Lawsuit%20Against%20NFL?_osource=db_npd_nbc_necn_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=%E2%80%98His%20Allegations%20Are%20False%27%3A%20Dolphins%20Owner%20Responds%20to%20Flores%27%20Lawsuit%20Against%20NFL&#038;url=https%3A%2F%2Fwww.necn.com%2Fnews%2Fsports%2Fhis-allegations-are-false-dolphins-owner-responds-to-flores-lawsuit-against-nfl-alleging-racist-hiring%2F2668907%2F?_osource=db_npd_nbc_necn_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=%E2%80%98His%20Allegations%20Are%20False%27%3A%20Dolphins%20Owner%20Responds%20to%20Flores%27%20Lawsuit%20Against%20NFL%0D%0A%0D%0Ahttps%3A%2F%2Fwww.necn.com%2Fnews%2Fsports%2Fhis-allegations-are-false-dolphins-owner-responds-to-flores-lawsuit-against-nfl-alleging-racist-hiring%2F2668907%2F?_osource=db_npd_nbc_necn_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
			<a href="#" data-service="comments">
			<span class="icon icon-comment-alt"></span>
		</a>
	</div>
		</div>
					<div id="div-gpt-ad-mobilemultibox_belowarticle" class="widget_ad_layers_ad_widget gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_belowarticle', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script>	<div id="taboola-below-article-thumbnails"></div>

	<script type="text/javascript">
		if (document.cookie.indexOf("scroll0=") < 0) {
			window._taboola = window._taboola || [];
			_taboola.push({
				article: 'auto',
				url: ''
			});
						_taboola.push({
				mode: 'thumbnails-a',
				container: 'taboola-below-article-thumbnails',
				placement: 'Below Article Thumbnails',
				target_type: 'mix'
			});
						_taboola.push({
				flush: true
			});
		};
	</script>
		<div id="mobile-native-below-article"></div>
	<script type="text/javascript">
		var isMobile = window.matchMedia('screen and (max-width: 767px)').matches;
		/** scroll cookie for scroll.com **/
		if (document.cookie.indexOf("scroll0=") < 0 && isMobile) {
			window._taboola = window._taboola || [];
			_taboola.push({
				mode: 'thumbs-feed-03-mobile',
				container: 'mobile-native-below-article',
				placement: 'Below Article Thumbnails - Fallback',
				target_type: 'text'
			});
		};
	</script>
					</div>
		</div>
		<div class="section-content--secondary">
			<aside class="sidebar article-sidebar">
						<section id="nbc_most_popular-2" class="widget widget_nbc_most_popular"><div class="nbc-most-popular" data-react-component="MostPopular" data-title="Trending Stories" data-include-sponsored="true" data-beforetext="Presented By"></div></section><section id="ad_layers_ad_widget-2" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-topbox_558" class=" gpt-topbox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbox_558', format: 'topbox', targeting: {"slot":"topbox","pos":"topbox"} });
			</script></section><section id="nbc_weather_widget-3" class="widget widget_nbc_weather_widget">		<div class="nbc-weather-widget">
			<div class="nbc_owned_television_stations_weather_iframe">
	<h3>Weather Forecast</h3><div data-react-component="IframeLocation" data-market-name="Boston, MA"></div>
	<a class="weather-module__conditions" href="https://www.necn.com/weather/">
		<div data-react-component="IframeConditions" data-location="2201"></div>
	</a>
		<div class="widget_sponsor">
		<div id="div-gpt-ad-logo_weather_672" class="sponsored-ad-unit gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_weather_672', format: 'logo', targeting: {"module":"weather","slot":"logo","pos":"logo"} });
			</script>	</div>
</div>
		</div>
		</section><section id="nbc_civic_science-2" class="widget widget_nbc_civic_science"><div id="civsci-1061260548" class="module-civicScience" data-tgtid="002b3e57-fcd5-a9f4-9dba-157688257e5f"></div></section><section id="ad_layers_ad_widget-6" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-bottombox_363" class=" gpt-bottombox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'bottombox_363', format: 'bottombox', targeting: {"slot":"bottombox","pos":"bottombox"} });
			</script></section><section id="ad_layers_ad_widget-12" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-interstitial_776" class=" gpt-interstitial" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'interstitial_776', format: 'interstitial', targeting: {"slot":"interstitial","pos":"interstitial"} });
			</script></section><section id="ad_layers_ad_widget-13" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilebackstage_459" class=" gpt-mobilebackstage" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilebackstage_459', format: 'mobilebackstage', targeting: {"slot":"mobilebackstage","pos":"mobilebackstage"} });
			</script></section><section id="nbc_newsletter-2" class="widget widget_nbc_newsletter"><div class="newsletter-widget"
				data-react-component="NewsletterWidget"
				data-title="Subscribe to our Newsletters"
				data-description="Sign up to receive breaking news alerts in your inbox."
				data-newsletter-id="NECN_BreakingNews"
				data-privacy-link="http://www.nbcuniversal.com/privacy/"
				data-newsletter-link=""
				data-nonce="36ce9cfb1f"
				></div></section>			</aside>
		</div>
	</div>
</article>

			</main>
		</div>

		
	</div><!-- #content -->
	
<footer role="contentinfo" class="site-footer">
	<div class="site-footer__wrapper">
		<div class="site-footer__identity">
							<a href="https://www.necn.com/" class="site-footer__logo">
					<img
						src="https://media.necn.com/2021/04/NECN@3x.png?fit=375%2C120&#038;quality=85&#038;strip=all"
						alt="NECN"
						loading="lazy"
					/>
				</a>
			
			
			<ul class="site-footer__social-list">
				
									<li class="site-footer__social-list-item facebook">
						<a href="http://www.facebook.com/necntv" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Facebook</span>
							<span class="icon icon-facebook-f"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item twitter">
						<a href="https://twitter.com/NECN" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Twitter</span>
							<span class="icon icon-twitter"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item instagram">
						<a href="https://instagram.com/necntv" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Instagram</span>
							<span class="icon icon-instagram"></span>
						</a>
					</li>
							</ul>
		</div>

		<ul id="menu-footer" class="footer-menu site-footer__menu-primary"><li id="menu-item-2183207" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2183207"><a href="/investigations/submit-tip/">Submit Tips for Investigations</a></li>
<li id="menu-item-2158151" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2158151"><a href="https://www.necn.com/contact-us/">Contact Us</a></li>
<li id="menu-item-2183206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2183206"><a href="https://www.necn.com/newsletters/">Newsletters</a></li>
</ul><ul id="menu-primary" class="footer-menu-secondary site-footer__menu-secondary"><li id="menu-item-2153046" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2153046"><a href="https://www.necn.com/send-feedback/">Send Feedback</a></li>
<li id="menu-item-2153048" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2153048"><a href="https://www.necn.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-2153041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2153041"><a target="_blank" rel="noopener noreferrer" href="https://www.nbcuniversal.com/privacy/?brandA=Owned_Stations&#038;intake=NECN">Privacy Policy</a></li>
<li id="menu-item-2153043" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2153043"><a target="_blank" rel="noopener noreferrer" href="https://www.nbcuniversal.com/privacy/notrtoo?brandA=Owned_Stations&#038;intake=NECN">Do Not Sell My Personal Information</a></li>
<li id="menu-item-2153045" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2153045"><a href="mailto:NECNViewerMail.Advertising@nbcuni.com?subject=Advertise%20with%20Us%20HP">Advertise with us</a></li>
<li id="menu-item-2300877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2300877"><a href="https://www.nbcuniversal.com/privacy/california-consumer-privacy-act?intake=NECN">CA Notice</a></li>
<li id="menu-item-2153044" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2153044"><a href="https://www.nbcuniversal.com/privacy/cookies#accordionheader2">AdChoices</a></li>
</ul>
				<div class="site-footer__corporate">
			
			<span class="site-footer__corporate-copyright">
				Copyright © 2022 NBCUniversal Media, LLC. All rights reserved			</span>
		</div>
	</div><!-- wrapper -->
</footer><!-- #colophon -->
</div><!-- #page -->

	<script type="text/javascript">
	(function() {
		var _sf_async_config      = window._sf_async_config = window._sf_async_config || {};
		_sf_async_config.domain   = "necn.com";
		_sf_async_config.uid      = 15527;
		_sf_async_config.sections = "sports";
		_sf_async_config.authors  = "NBC 6, The Associated Press";
		_sf_async_config.title    = "\u2018His Allegations Are False': Dolphins Owner Responds to Flores' Lawsuit Against NFL";
		
		var e = document.createElement('script');
		var n = document.getElementsByTagName('script')[0];
		e.type = 'text/javascript';
		e.async = true;
		e.src = '//static.chartbeat.com/js/chartbeat.js';
		n.parentNode.insertBefore(e, n);
	})();
	</script>
			<!-- Begin comScore Tag -->
		<script>
			(function() {
				var usPrivacyCookie = new RegExp("usprivacy=([^;]+)").exec(document.cookie),
					usPrivacy = null !== usPrivacyCookie ? unescape(usPrivacyCookie[1]) : undefined,
					csUCFR = '1YYN' === usPrivacy ? '0': '',
					s = document.createElement("script"),
					el = document.getElementsByTagName("script")[0];

				window._comscore = window._comscore || [];

				window._comscore.push({
					c1: "2",
					c2: "6035083",
					cs_ucfr: csUCFR,
				});

				s.async = true;
				s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
				el.parentNode.insertBefore(s, el);
			})();
		</script>
		<noscript>
			<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035083&cv=2.0&cj=1" />
		</noscript>
		<!-- End comScore Tag -->
				<script type="text/javascript">
		(function() {
			var loaderUrl, scriptType;
			window._taboola = window._taboola || [];
			window._newsroom = window._newsroom || [];
			const taboola_config = {};

			taboola_config[decodeURIComponent( 'article' )] = decodeURIComponent( '2668907' );
			taboola_config['url'] = document.URL;
			taboola_config['tracking'] = '_osource=taboola-recirc';
			_taboola.push(taboola_config);

						scriptType = 'tb_loader_script';
			loaderUrl = 'https://cdn.taboola.com/libtrc/nbcots-network/loader.js';
			
			!function (e, f, u, i) {
				e.async = 1;
				e.src = u;
				e.id = i;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			loaderUrl,
			scriptType);

			!function (e, f, u) {
				e.async = 1;
				e.src = u;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			"\/\/c2.taboola.com\/nr\/nbcots-necn\/newsroom.js");
		}());
		</script>
				<div class="facebook-comments">
			<button class="facebook-comments__close"><span class="icon icon-chevron-left"></span> Back to Article</button>
			<div class="fb-comments" data-href="https://www.necn.com/news/sports/his-allegations-are-false-dolphins-owner-responds-to-flores-lawsuit-against-nfl-alleging-racist-hiring/2668907/" data-width="100%"></div>
		</div>
		<div class="flyout-nav" data-component="flyoutNav">
	<button class="flyout-nav__close"><span class="icon icon-times"></span> <span class="screen-reader-text">Close Menu</span></button>
	<div class="flyout-nav__logo">
		<a href="https://www.necn.com/">
					<img
						src="https://media.necn.com/2021/04/NECN@3x.png?fit=375%2C120&#038;quality=85&#038;strip=all"
						alt="NECN"
					/>
		</a>
	</div>
	<div class="flyout-nav__search">
<form class="search-form" role="search" method="get" action="https://www.necn.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
</div>
	<div class="flyout-nav__menu">
		<div class="flyout-nav__menu--upper">
							<a data-lid="Meet the Team" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="https://www.necn.com/contact-us/">
					Meet the Team				</a>
							<a data-lid="Coronavirus Pandemic" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/coronavirus/">
					Coronavirus Pandemic				</a>
							<a data-lid="NBCLX" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/lx/">
					NBCLX				</a>
							<a data-lid="Local" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/local/">
					Local				</a>
							<a data-lid="Massachusetts" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/massachusetts/">
					Massachusetts				</a>
							<a data-lid="Connecticut" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/connecticut/">
					Connecticut				</a>
							<a data-lid="Maine" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/maine/">
					Maine				</a>
							<a data-lid="New Hampshire" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/new-hampshire/">
					New Hampshire				</a>
							<a data-lid="Rhode Island" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/rhode-island/">
					Rhode Island				</a>
							<a data-lid="Vermont" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/vermont/">
					Vermont				</a>
							<a data-lid="Weather" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/weather/">
					Weather				</a>
							<a data-lid="Maps &amp; Radar" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/maps/">
					Maps &amp; Radar				</a>
							<a data-lid="Weather Alerts" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/severe-weather-alerts/">
					Weather Alerts				</a>
							<a data-lid="School Closing Alerts" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.necn.com/weather/school-closings/">
					School Closing Alerts				</a>
							<a data-lid="Sports" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/sports/">
					Sports				</a>
							<a data-lid="Traffic" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/traffic/">
					Traffic				</a>
							<a data-lid="Business" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/business/">
					Business				</a>
							<a data-lid="Virtual Connection" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.necn.com/news/national-international/virtual-connection-community-services-for-you-and-your-family-during-the-coronavirus-pandemic/2251566/">
					Virtual Connection				</a>
							<a data-lid="This Week in Business" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/business/twib/">
					This Week in Business				</a>
							<a data-lid="Chief Execs Club" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/chief-execs-club/">
					Chief Execs Club				</a>
					</div>
		<div class="flyout-nav__menu--lower">
							<a data-lid="TV Listings" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.necn.com/live/">
					TV Listings				</a>
							<a data-lid="Submit Photos and Video" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/ugc/">
					Submit Photos and Video				</a>
							<a data-lid="Newsletters" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/newsletters/">
					Newsletters				</a>
							<a data-lid="Our Apps" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/products/">
					Our Apps				</a>
							<a data-lid="Cozi TV" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://cozitv.com/">
					Cozi TV				</a>
					</div>
	</div>
	<div class="flyout-nav__social">
		<h4 class="flyout-nav__social-heading">Follow Us</h4>
		<ul class="flyout-nav__social-list">
			
							<li class="site-footer__social-list-item facebook" rel="noopener noreferrer">
					<a href="http://www.facebook.com/necntv" target="_blank">
						<span class="screen-reader-text">Facebook</span>
						<span class="icon icon-facebook-f"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item twitter" rel="noopener noreferrer">
					<a href="https://twitter.com/NECN" target="_blank">
						<span class="screen-reader-text">Twitter</span>
						<span class="icon icon-twitter"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item instagram" rel="noopener noreferrer">
					<a href="https://instagram.com/necntv" target="_blank">
						<span class="screen-reader-text">Instagram</span>
						<span class="icon icon-instagram"></span>
					</a>
				</li>
					</ul>
	</div>
</div>
<a class="flyout-contact-button" data-lid="Contact Us" data-lpos="hamburger-menu"
			href="/contact-us"
	>
	Contact Us</a>
<link rel='stylesheet' id='all-css-0' href='https://www.necn.com/_static/??-eJyd0D1uxCAQBeALZcE2GEMRbZ0mSpcygpkhi8SPZXCsvX3YPUHiaop57yseP9YLlNwoN95ulKjy7OBSm22hZA4xPD5uDxE51MpTqe2jrHu0G5sGsos3fjFS+1GLSWvJUsisB1/4P+FMR43UGm2fAb+pMZgVCUSnyUwKBrRO+9O6L6XLDFF4JyWoGUBpa0bl8LwZ72Vv7/aHyb6EAQd27qh2ShK60+xBtse2t96pbAEU6GAAS7MfAIz3fx7heeFprtHeafuqqc9we3Sv6XVUUmgxKiF/AUS7uQI=' type='text/css' media='all' />
<script src='https://www.necn.com/wp-content/mu-plugins/jetpack-9.4/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script src='https://www.necn.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://www.necn.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.necn.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://www.necn.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://www.necn.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.necn.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.necn.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script src='https://www.necn.com/wp-includes/js/dist/i18n.min.js?ver=4ab02c8fd541b8cfb8952fe260d21f16' id='wp-i18n-js'></script>
<script src='https://www.necn.com/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.21' id='lodash-js'></script>
<script id='lodash-js-after'>
window.lodash = _.noConflict();
</script>
<script src='https://www.necn.com/wp-includes/js/dist/url.min.js?ver=d80b474ffb72c3b6933165cc1b3419f6' id='wp-url-js'></script>
<script src='https://www.necn.com/wp-includes/js/dist/hooks.min.js?ver=63769290dead574c40a54748f22ada71' id='wp-hooks-js'></script>
<script id='wp-api-fetch-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script src='https://www.necn.com/wp-includes/js/dist/api-fetch.min.js?ver=0bb73d10eeea78a4d642cdd686ca7f59' id='wp-api-fetch-js'></script>
<script id='wp-api-fetch-js-after'>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</script>
<script src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/common.56e7b20ae0d7732f3867.bundle.min.js?ver=1.0.2' id='nbc-common-js-js'></script>
<script async src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/weatherConditions.4c15723b488ed01f093e.bundle.min.js?ver=1.0.2' id='nbc-weather-conditions-js'></script>
<script async src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/global.024a9d5c8f45734ea1f0.bundle.min.js?ver=1.0.2' id='nbc-global-js'></script>
<script async src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/article.8551b8cf1400c2162a2f.bundle.min.js?ver=1.0.2' id='nbc-article-js-js'></script>
<script src='https://ak.sail-horizon.com/spm/spm.v1.min.js?ver=1.0.0' id='nbc-sailthru-js'></script>
<script id='nbc-sailthru-js-after'>
if ("undefined" !== typeof Sailthru) { Sailthru.init({"customerId":"757cc89c051f4552fa5708e6f3b93a01"}); }
</script>
<script src='https://www.necn.com/wp-content/themes/nbc-station/static/js/zepto.min.js?ver=1.0.2' id='zepto-js'></script>
<script src='https://www.necn.com/wp-content/themes/nbc-station/static/js/player.6.1.3.js?ver=1.0.2' id='pdk-js'></script>
<script src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/videoPlayer.2aaf2e5451de9c7a5627.bundle.min.js?ver=1.0.2' id='nbc-video-player-js'></script>
<script src='https://native.sharethrough.com/assets/sfp.js?ver=5.5.8' id='sharethrough-js'></script>
<script async src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/flyoutNav.57fd800295608226f92a.bundle.min.js?ver=1.0.2' id='nbc-flyout-nav-js'></script>
<script src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/articleContent.002368ae3a0d6363e579.bundle.min.js?ver=1.0.2' id='nbc-article-content-js'></script>
<script defer src='https://js-sec.indexww.com/ht/p/185796-256714881512110.js?ver=1.0.2' id='nbc-index-exchange-js'></script>
<script src='https://z.moatads.com/nbcuyieldheader7581548001/moatheader.js?ver=1.0.0' id='moat-js'></script>
<script src='https://www.necn.com/wp-includes/js/wp-embed.min.js?ver=5.5.8' id='wp-embed-js'></script>
<script src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/mostPopular.d66100ae93858ea07733.bundle.min.js?ver=1.0.2' id='nbc-most-popular-js'></script>
<script src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/civicScience.4db1dfb9fe92d553e9e3.bundle.min.js?ver=1.0.2' id='civic-science-js'></script>
<script src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/newsletterWidget.48e20db14ed1c3b53059.bundle.min.js?ver=1.0.2' id='newsletter-widget-js'></script>
<script src='https://stats.wp.com/e-202205.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4.1',blog:'165596161',post:'2668907',tz:'-5',srv:'www.necn.com'} ]);
	_stq.push([ 'clickTrackerInit', '165596161', '2668907' ]);
</script>

</body>
</html>
