<!doctype html>
<html lang="en-US" class="">
<head>
	<meta charset="UTF-8">
		<meta name="viewport" content="width=device-width, initial-scale=1">
		
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<title>Sports World Reacts to Brittney Griner&#8217;s Russian Prison Release &#8211; NECN</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//z.moatads.com' />
<link rel='dns-prefetch' href='//assets.adobedtm.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//ak.sail-horizon.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NECN &raquo; Feed" href="https://www.necn.com/?rss=y" />
<style class="wp-asset-manager nbc-fonts" type="text/css">@font-face{font-display:swap;font-family:"Arthouse";font-style:normal;font-weight:500;src:local("Arthouse Medium"),url(/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Medium.woff2) format("woff2")}@font-face{font-display:swap;font-family:"Arthouse";font-style:normal;font-weight:700;src:local("Arthouse Bold"),url(/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Bold.woff2) format("woff2")}@font-face{font-display:swap;font-family:"Arthouse";font-style:normal;font-weight:900;src:local("Arthouse Black"),url(/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Black.woff2) format("woff2")}@font-face{font-display:swap;font-family:"Arthouse";font-style:italic;font-weight:900;src:local("Arthouse Black Italic"),url(/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-BlackItalic.woff2) format("woff2")}@font-face{font-display:swap;font-family:"Arthouse";font-style:italic;font-weight:700;src:local("Arthouse Bold Italic"),url(/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-BoldItalic.woff2) format("woff2")}@font-face{font-display:swap;font-family:"Arthouse";font-style:italic;font-weight:500;src:local("Arthouse Medium Italic"),url(/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-MediumItalic.woff2) format("woff2")}@font-face{font-display:swap;font-family:"Arthouse";font-style:italic;font-weight:400;src:local("Arthouse Italic"),url(/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Italic.woff2) format("woff2")}@font-face{font-display:swap;font-family:"Arthouse";font-style:normal;font-weight:300;src:local("Arthouse Light"),url(/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Light.woff2) format("woff2")}@font-face{font-display:swap;font-family:"Arthouse";font-style:italic;font-weight:300;src:local("Arthouse Light Italic"),url(/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-LightItalic.woff2) format("woff2")}@font-face{font-display:swap;font-family:"Roboto";font-style:normal;font-weight:400;src:local("Roboto Regular"),url(/wp-content/themes/nbc-station/client/build/media/Roboto-Regular.woff2) format("woff2")}@font-face{font-display:swap;font-family:"Roboto";font-style:normal;font-weight:500;src:local("Roboto Medium"),url(/wp-content/themes/nbc-station/client/build/media/Roboto-Medium.woff2) format("woff2")}@font-face{font-display:swap;font-family:"Roboto";font-style:italic;font-weight:500;src:local("Roboto MediumItalic"),url(/wp-content/themes/nbc-station/client/build/media/Roboto-MediumItalic.woff2) format("woff2")}@font-face{font-display:swap;font-family:"Roboto";font-style:normal;font-weight:700;src:local("Roboto Bold"),url(/wp-content/themes/nbc-station/client/build/media/Roboto-Bold.woff2) format("woff2")}@font-face{font-display:swap;font-family:"Roboto";font-style:italic;font-weight:700;src:local("Roboto BoldItalic"),url(/wp-content/themes/nbc-station/client/build/media/Roboto-BoldItalic.woff2) format("woff2")}

/*# sourceMappingURL=fonts.cd00e5c5d59aff84af8c.min.css.map*/</style><style class="wp-asset-manager nbc-global" type="text/css">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</style><style class="wp-asset-manager nbc-common" type="text/css">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</style><style class="wp-asset-manager nbc-article" type="text/css">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</style><style class="wp-asset-manager nbc-article-content" type="text/css">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</style><style class="wp-asset-manager nbc-blocks" type="text/css">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</style><style class="wp-asset-manager nbc-most-popular" type="text/css">@media(max-width: 47.9375rem){.widget_nbc_most_popular.widget{display:none}}.widget_nbc_most_popular .post__image__wrap{height:3.0625rem;margin-right:.625rem;max-height:3.0625rem;max-width:5.5rem;min-height:3.0625rem;min-width:5.5rem;overflow:hidden;width:5.5rem}.widget_nbc_most_popular .post__image__wrap img{max-width:5.5rem;min-height:3.0625rem;min-width:5.5rem}.widget_nbc_most_popular .post__category,.widget_nbc_most_popular .post__sponsor{font-size:.6875rem;font-weight:800;letter-spacing:1px;line-height:1;margin-bottom:.1875rem;text-transform:uppercase}.widget_nbc_most_popular .post__category a,.widget_nbc_most_popular .post__sponsor a{color:#144aa8;text-decoration:none}.widget_nbc_most_popular .post__title{font-family:"Arthouse",sans-serif;font-size:.9375rem;font-weight:500;line-height:1.35;margin-bottom:.1875rem}.widget_nbc_most_popular .post__title a{color:#000;text-decoration:none}.widget_nbc_most_popular .post__sponsor{color:#0a8539}.widget_nbc_most_popular .most-popular__header{-webkit-box-align:end;-ms-flex-align:end;align-items:flex-end;display:-webkit-box;display:-ms-flexbox;display:flex;-webkit-box-orient:horizontal;-webkit-box-direction:normal;-ms-flex-direction:row;flex-direction:row;-webkit-box-pack:justify;-ms-flex-pack:justify;justify-content:space-between}.widget_nbc_most_popular .sponsored-ad-unit{display:-webkit-box;display:-ms-flexbox;display:flex;-webkit-box-orient:vertical;-webkit-box-direction:normal;-ms-flex-direction:column;flex-direction:column;margin-bottom:1.125rem;position:relative}.widget_nbc_most_popular .sponsored-ad-unit::before{color:#000;content:"";font-family:"Arthouse",sans-serif;font-size:.6875rem;font-weight:700;position:absolute;right:0;text-align:right;text-transform:uppercase;top:-1.0625rem}.widget_nbc_most_popular .sponsored-ad-unit.logo-rendered::before{content:attr(data-beforetext)}.widget_nbc_most_popular .sponsored-ad-unit:empty::before{content:""}.widget_nbc_most_popular .sponsored-ad-unit div{display:inline-block}.most-popular__post{-webkit-box-align:start;-ms-flex-align:start;align-items:flex-start;border-bottom:1px solid #d8d8d8;display:-webkit-box;display:-ms-flexbox;display:flex;font-size:.75rem;padding:1rem 0 .6875rem}.most-popular__post:first-child{padding-top:0}.most-popular__post:last-child{border-bottom:0}.most-popular__post .most-popular__presented_by{color:#767676;font-family:"Arthouse",sans-serif;font-size:.5625rem}

/*# sourceMappingURL=mostPopular.f58524ab569a30c1fff2.min.css.map*/</style><style id='global-styles-inline-css'>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</style>
<script id='ad-layers-dfp-js-extra'>
var adLayersDFP = {"layerDebugLabel":"Current ad layer","consoleDebugLabel":"Switch to Google console","adUnitPrefix":"div-gpt-ad-"};
</script>
<script src='https://www.necn.com/wp-content/plugins/ad-layers-nbc/js/ad-layers-dfp.js?ver=0.0.10' id='ad-layers-dfp-js'></script>
<script id='ad-layers-js-extra'>
var adLayersAdServer = {"jsAPIClass":"AdLayersDFPAPI"};
</script>
<script src='https://www.necn.com/wp-content/plugins/ad-layers-nbc/js/ad-layers.js?ver=0.0.10' id='ad-layers-js'></script>
<link rel="https://api.w.org/" href="https://www.necn.com/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.necn.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.necn.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.6" />
<link rel="canonical" href="https://www.nbcsports.com/chicago/sports-world-reacts-brittney-griners-russian-prison-release" />
<link rel="alternate" type="application/json+oembed" href="https://www.necn.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.necn.com%2Fnews%2Fsports%2Fsports-world-reacts-to-brittney-griners-russian-prison-release%2F2886628%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.necn.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.necn.com%2Fnews%2Fsports%2Fsports-world-reacts-to-brittney-griners-russian-prison-release%2F2886628%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
	<script>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</script><style type="text/css">
	.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%); }
</style>
<meta property="og:site_name" content="NECN" /><meta name="google-site-verification" content="E-egfefm-gv7oaXIe_jmNFN6dmiCZmu4-1sgCkoQTV8" /><meta property="fb:app_id" content="424638114340719" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@NECN" /><meta name="twitter:creator" content="@NECN" /><meta property="og:type" content="article" /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta name="article:publisher" content="http://www.facebook.com/necntv" /><meta name="description" content="With WNBA star Brittney Griner&#039;s release from prison brewing Thursday morning, professional athletes come together and react to the news." /><meta property="og:description" content="With WNBA star Brittney Griner&#039;s release from prison brewing Thursday morning, professional athletes come together and react to the news." /><meta name="twitter:description" content="With WNBA star Brittney Griner&#039;s release from prison brewing Thursday morning, professional athletes come together and react to the news." /><meta property="og:title" content="Sports World Reacts to Brittney Griner&#039;s Russian Prison Release" /><meta name="twitter:title" content="Sports World Reacts to Brittney Griner&#039;s Russian Prison Release" /><meta name="keywords" content="Brittney Griner" /><meta property="og:url" content="https://www.necn.com/news/sports/sports-world-reacts-to-brittney-griners-russian-prison-release/2886628/" /><meta name="twitter:url" content="https://www.necn.com/news/sports/sports-world-reacts-to-brittney-griners-russian-prison-release/2886628/" /><meta name="sailthru.title" content="Sports World Reacts to Brittney Griner&#039;s Russian Prison Release" /><meta name="sailthru.description" content="With WNBA star Brittney Griner&#039;s release from prison brewing Thursday morning, professional athletes come together and react to the news." /><meta name="sailthru.tags" content="Brittney Griner" /><meta name="sailthru.tags" content="Brittney Griner" /><meta name="sailthru.type" content="article" /><meta name="sailthru.date" content="2022-12-08T12:30:00+00:00" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:image" content="https://media.necn.com/2022/12/Brittney20Griner20Phoenix20Mercury20GETTY.jpg?quality=85&#038;strip=all&#038;resize=1200%2C675" /><meta name="twitter:image" content="https://media.necn.com/2022/12/Brittney20Griner20Phoenix20Mercury20GETTY.jpg?quality=85&#038;strip=all&#038;resize=1200%2C675" /><meta name="taboola_lead" content="video" /><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":"https:\/\/www.necn.com\/news\/sports\/sports-world-reacts-to-brittney-griners-russian-prison-release\/2886628\/","headline":"Sports World Reacts to Brittney Griner's Russian Prison Release","datePublished":"2022-12-08T12:30:00","dateModified":"2022-12-08T13:04:03","description":"With WNBA star Brittney Griner's release from prison brewing Thursday morning, professional athletes come together and react to the news.","speakable":{"@type":"SpeakableSpecification","cssSelector":[".article-headline",".article-subtitle"]},"keywords":"Brittney Griner","publisher":{"@type":"Organization","name":"NECN","logo":{"@type":"ImageObject","height":60,"url":"https:\/\/media.necn.com\/wp-content\/uploads\/2022\/05\/amp_square_necn.png","width":160}},"image":{"@type":"ImageObject","height":675,"url":"https:\/\/media.necn.com\/2022\/12\/Brittney20Griner20Phoenix20Mercury20GETTY.jpg?quality=85&strip=all&resize=1200%2C675","width":1200},"video":{"@type":"VideoObject","contentUrl":"https:\/\/www.necn.com\/news\/sports\/sports-world-reacts-to-brittney-griners-russian-prison-release\/2886628\/","description":"With WNBA star Brittney Griner&#8217;s release from prison brewing Thursday morning, professional athletes come together and react to the news.","duration":"PT03M58S","name":"Sports World Reacts to Brittney Griner's Russian Prison Release","thumbnailUrl":"https:\/\/media.necn.com\/2022\/12\/Brittney20Griner20Phoenix20Mercury20GETTY.jpg?quality=85&strip=all&resize=1200%2C675","uploadDate":"2022-12-08T12:30:00"},"author":{"@type":"Person","name":"Marsha Green"}}</script>							<script type='text/javascript'>
				var dfpAdUnits = {};
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
				var gads = document.createElement('script');
				gads.async = true;
				gads.type = 'text/javascript';
				var useSSL = 'https:' == document.location.protocol;
				gads.src = (useSSL ? 'https:' : 'http:') +
				'//www.googletagservices.com/tag/js/gpt.js';
				var node = document.getElementsByTagName('script')[0];
				node.parentNode.insertBefore(gads, node);
				})();
				</script>
												<script type="text/javascript">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</script>
			<link rel="icon" href="https://media.necn.com/2019/09/cropped-NECN-1.png?fit=32%2C32&#038;quality=85&#038;strip=all" sizes="32x32" />
<link rel="icon" href="https://media.necn.com/2019/09/cropped-NECN-1.png?fit=192%2C192&#038;quality=85&#038;strip=all" sizes="192x192" />
<link rel="apple-touch-icon" href="https://media.necn.com/2019/09/cropped-NECN-1.png?fit=180%2C180&#038;quality=85&#038;strip=all" />
<meta name="msapplication-TileImage" content="https://media.necn.com/2019/09/cropped-NECN-1.png?fit=270%2C270&#038;quality=85&#038;strip=all" />
</head>

<body class="post-template-default single single-post postid-2886628 single-format-standard station-nbc necn has-featured-image short-hero">
	<div id="leaderboard" class="leaderboard-ad">
		<div id="div-gpt-ad-topbanner_" class=" gpt-topbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbanner_', format: 'topbanner', targeting: {"slot":"topbanner","pos":"topbanner"} });
			</script><div id="div-gpt-ad-mobiletopbanner_" class=" gpt-mobiletopbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobiletopbanner_', format: 'mobiletopbanner', targeting: {"slot":"mobiletopbanner","pos":"mobiletopbanner"} });
			</script>	</div>
	<div id="page" class="site" data-component="wrapper">
	
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner" data-component="siteHeader">
		<div class="site-header__primary">
		<div class="site-header__wrap">
							<div class="site-header__logo">
					<a href="https://www.necn.com/">
						<img src="https://media.necn.com/2019/09/NECN_On_Dark@3x-3.png?fit=420%2C120&#038;quality=85&#038;strip=all&#038;w=140&#038;h=40" srcset="https://media.necn.com/2019/09/NECN_On_Dark@3x-3.png?fit=420%2C120&amp;quality=85&amp;strip=all&amp;w=140&amp;h=40 1x, https://media.necn.com/2019/09/NECN_On_Dark@3x-3.png?fit=420%2C120&amp;quality=85&amp;strip=all&amp;w=280&amp;h=80 2x, https://media.necn.com/2019/09/NECN_On_Dark@3x-3.png?fit=420%2C120&amp;quality=85&amp;strip=all&amp;w=420&amp;h=120 3x" alt="NECN" height="40" width="140" />					</a>
				</div>
						<div class="site-header__nav-search">
				<div class="site-header__nav-main">
					<button class="site-header__nav-main-toggle">
						<span class="site-header__nav-main-toggle-text">Main Navigation</span>
					</button>
				</div>
				<div class="site-header__search" data-component="headerSearch">
					<button class="site-header__search-toggle">
						<span class="site-header__search-toggle-text">Search</span>
					</button>
					<div class="site-header__search-form">
						
<form class="search-form" role="search" method="get" action="https://www.necn.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input class="search-form-input" type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
					</div>
				</div>
			</div>
			<div class="site-header__animated-section">
				<nav class="site-header__nav-sections">
					<div class="menu-lower-flyout-menu-container"><nav id="primary-menu" class="menu"><a data-lid="Weather" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/weather/">Weather</a></li>
<a data-lid="Investigations" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/investigations/">Investigations</a></li>
<a data-lid="Videos" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/videos/">Videos</a></li>
<a data-lid="Entertainment" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/entertainment/">Entertainment</a></li>
<a data-lid="Politics" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/politics/">Politics</a></li>
<a data-lid="Business" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/business/">Business</a></li>
<a data-lid="Newsletters" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="https://www.necn.com/newsletters/">Newsletters</a></li>
</nav></div>				</nav>
				<div class="site-header__weather-tv">
					<div
						class="site-header__local-weather"
						data-react-component="NBCWeather"
						data-view="conditions"
					>
					</div>
										<a class="site-header__live-tv" href="https://www.necn.com/live">Live TV</a>
									</div>
				<button class="site-header__mobile-share-toggle">
					<span class="text-share">Share</span>
					<span class="text-close">Close</span>
				</button>
			</div>
		</div> <!-- site-header__wrap -->
	</div> <!-- site-header__primary -->
	<div class="site-header__secondary">
		<div class="site-header__wrap">
							<div class="site-header__trending">
					<span class="site-header__trending-label">Trending</span>
											<nav class="site-header__trending-nav">
												<a data-lid="World Cup" data-lpos="trending-stories-module" href="https://www.necn.com/news/sports/world-cup-2022/" class="site-header__trending-nav-item">World Cup</a>
					<a data-lid="Fútbol y Soccer Podcast" data-lpos="trending-stories-module" href="https://www.necn.com/news/local/world-cup-podcast-spanish-english/2828172/" class="site-header__trending-nav-item">Fútbol y Soccer Podcast</a>
					<a data-lid="Eat New England" data-lpos="trending-stories-module" href="https://www.necn.com/eat-new-england/" class="site-header__trending-nav-item">Eat New England</a>
					<a data-lid="Morning Chat" data-lpos="trending-stories-module" href="https://www.necn.com/morning-chat/" class="site-header__trending-nav-item">Morning Chat</a>
					<a data-lid="RealiTea" data-lpos="trending-stories-module" href="https://www.necn.com/realitea-with-derek-z/" class="site-header__trending-nav-item">RealiTea</a>
					<a data-lid="Mom 2 Mom" data-lpos="trending-stories-module" href="https://www.necn.com/mom-2-mom/" class="site-header__trending-nav-item">Mom 2 Mom</a>
					<a data-lid="Chef&#039;s Pantry" data-lpos="trending-stories-module" href="/chefs-pantry/" class="site-header__trending-nav-item">Chef&#039;s Pantry</a>
					<a data-lid="On Her Mark" data-lpos="trending-stories-module" href="https://www.necn.com/entertainment/on-her-mark/" class="site-header__trending-nav-item">On Her Mark</a>
		
							</nav>
										<div class="site-header__trending-toggle">
						<button class="trending-toggle"><span class="screen-reader-text">Expand</span></button>
					</div>
				</div>

				
<div class="site-header__alerts">
	<div
		class="site-header__weather "
		data-react-component="NBCWeather"
		data-view="alerts"
		data-alert-singular="Weather Alert"
		data-alert-plural="Weather Alerts"
		data-zip-code="2201">
	</div>
	</div> <!-- site-header__wrap -->
					</div> <!-- site-header__secondary -->
	</div>
</header>
	<div id="content" class="site-content " data-component="formsContainer">
		<div id="primary" class="content-area">
			<main id="main" class="site-main">
				<article id="post-2886628" data-component="article">

	<div
			id="template-hero"
		class="template-hero "
		data-component="templateHero"
	>
			<div class="hero-background">
			<img 
				src="https://media.necn.com/2022/02/NECN-Maine-Coast.jpg?quality=85&#038;strip=all&#038;fit=4032%2C1162&#038;w=400&#038;h=44&#038;crop=1"
									srcset="https://media.necn.com/2022/02/NECN-Maine-Coast.jpg?quality=85&amp;strip=all&amp;fit=4032%2C1162&amp;w=400&amp;h=44&amp;crop=1 400w, https://media.necn.com/2022/02/NECN-Maine-Coast.jpg?quality=85&amp;strip=all&amp;fit=4032%2C1162&amp;w=500&amp;h=56&amp;crop=1 500w, https://media.necn.com/2022/02/NECN-Maine-Coast.jpg?quality=85&amp;strip=all&amp;fit=4032%2C1162&amp;w=600&amp;h=67&amp;crop=1 600w, https://media.necn.com/2022/02/NECN-Maine-Coast.jpg?quality=85&amp;strip=all&amp;fit=4032%2C1162&amp;w=700&amp;h=78&amp;crop=1 700w, https://media.necn.com/2022/02/NECN-Maine-Coast.jpg?quality=85&amp;strip=all&amp;fit=4032%2C1162&amp;w=800&amp;h=89&amp;crop=1 800w, https://media.necn.com/2022/02/NECN-Maine-Coast.jpg?quality=85&amp;strip=all&amp;fit=4032%2C1162&amp;w=900&amp;h=100&amp;crop=1 900w, https://media.necn.com/2022/02/NECN-Maine-Coast.jpg?quality=85&amp;strip=all&amp;fit=4032%2C1162&amp;w=1000&amp;h=111&amp;crop=1 1000w, https://media.necn.com/2022/02/NECN-Maine-Coast.jpg?quality=85&amp;strip=all&amp;fit=4032%2C1162&amp;w=1100&amp;h=122&amp;crop=1 1100w, https://media.necn.com/2022/02/NECN-Maine-Coast.jpg?quality=85&amp;strip=all&amp;fit=4032%2C1162&amp;w=1200&amp;h=133&amp;crop=1 1200w, https://media.necn.com/2022/02/NECN-Maine-Coast.jpg?quality=85&amp;strip=all&amp;fit=4032%2C1162&amp;w=1300&amp;h=144&amp;crop=1 1300w"
													sizes="100vw"
								class="hero-background__img" 
				fetchpriority="high" 
			/>
		</div>
	
	
	
					
	
	
	
	
	
	
	</div>
		<div class="section-content--header below-hero">
		<div class="article-eyebrow__container">
	<div class="article-eyebrow__wrap">
									<a class="article-eyebrow" href="https://www.necn.com/tag/brittney-griner/">Brittney Griner</a>						</div>
	</div>
<div class="article-header--wrap ">
	<h1 class="article-headline">
		Sports World Reacts to Brittney Griner's Russian Prison Release	</h1>
			<h2 class="article-subtitle">
			Griner was first detained in February and has remained in custody for seven months before being sentenced		</h2>
				
<div class="article-meta" data-component="articleMeta">
	<h4 class="article-byline">
					By Marsha Green							<span class="meta-dot">&bull;</span>
					
									<span class="time-wrap">
					<time class="entry-date published" datetime="2022-12-08T17:30:00-05:00">Published 55 mins ago</time>						<span class="meta-dot">&bull;</span>
					<time class="entry-date updated" datetime="2022-12-08T13:04:03-05:00">Updated 21 mins ago</time>				</span>
						</h4>
	<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.necn.com%2Fnews%2Fsports%2Fsports-world-reacts-to-brittney-griners-russian-prison-release%2F2886628%2F&#038;Sports%20World%20Reacts%20to%20Brittney%20Griner%27s%20Russian%20Prison%20Release?_osource=db_npd_nbc_necn_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Sports%20World%20Reacts%20to%20Brittney%20Griner%27s%20Russian%20Prison%20Release&#038;url=https%3A%2F%2Fwww.necn.com%2Fnews%2Fsports%2Fsports-world-reacts-to-brittney-griners-russian-prison-release%2F2886628%2F?_osource=db_npd_nbc_necn_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=Sports%20World%20Reacts%20to%20Brittney%20Griner%27s%20Russian%20Prison%20Release%0D%0A%0D%0Ahttps%3A%2F%2Fwww.necn.com%2Fnews%2Fsports%2Fsports-world-reacts-to-brittney-griners-russian-prison-release%2F2886628%2F?_osource=db_npd_nbc_necn_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
	</div>
				</div>
		</div>
	</div>
		<div class="section-content--full below-hero">
		<div class="section-content--primary">
			<div class="article-content--wrap">
					<figure class="article-featured-media video-lead">
					<div class="video-flyout" data-component="videoFlyout">
				<div class="video-flyout__container">
					<div
			data-react-component="VideoPlayer"
		data-meta="{&quot;spay_email&quot;:&quot;&quot;,&quot;syndicated_id&quot;:&quot;1:1:7237328&quot;,&quot;should_nationalize&quot;:false,&quot;nbc_first_published_date&quot;:&quot;&quot;,&quot;nbc_prevent_modified_update&quot;:false,&quot;nbc_linkout_title&quot;:&quot;&quot;,&quot;nbc_linkout_url&quot;:&quot;&quot;,&quot;nbc_linkout_excerpt_link&quot;:&quot;&quot;,&quot;nbc_primary_category_id&quot;:190,&quot;nbc_primary_tag_id&quot;:694220,&quot;nbc_social_page_title&quot;:&quot;&quot;,&quot;nbc_page_title&quot;:&quot;&quot;,&quot;nbc_seo_description&quot;:&quot;&quot;,&quot;nbc_social_description&quot;:&quot;&quot;,&quot;nbc_national_headline&quot;:&quot;&quot;,&quot;entities&quot;:&quot;&quot;,&quot;nbc_canonical_market&quot;:&quot;8&quot;,&quot;nbc_canonical_url&quot;:&quot;&quot;,&quot;nbc_hide_from_recirculation&quot;:&quot;&quot;,&quot;nbc_hide_from_search&quot;:&quot;&quot;,&quot;nbc_syndication_category&quot;:&quot;1:1:190&quot;,&quot;nbc_national_collections&quot;:[],&quot;nopreroll&quot;:false,&quot;video_copyright&quot;:&quot;NBCUniversal Media, LLC&quot;,&quot;sst_source_id&quot;:&quot;&quot;,&quot;nbc_disable_legacy_embeds&quot;:false,&quot;nbc_feed_loader_prevent_updates&quot;:&quot;&quot;,&quot;post_video_prompt&quot;:&quot;&quot;,&quot;nbc_checkout_experience_enabled&quot;:false,&quot;rsn_disable_insider&quot;:false,&quot;desktopFlashPid&quot;:&quot;&quot;,&quot;mpx_dfxp_url&quot;:&quot;&quot;,&quot;mp4_url&quot;:&quot;&quot;,&quot;mpx_download_pid&quot;:&quot;SrkRwiWiBBe1&quot;,&quot;mpx_download_pid_high&quot;:&quot;B2Qzw7A9Nlpa&quot;,&quot;mpx_high_id&quot;:&quot;&quot;,&quot;mpx_high_url&quot;:&quot;&quot;,&quot;mpx_is_livestream&quot;:&quot;&quot;,&quot;mpx_m3upid&quot;:&quot;&quot;,&quot;mpx_pid&quot;:&quot;Aw30xJowAJbK&quot;,&quot;mpx_thumbnail_url&quot;:&quot;https:\/\/media.necn.com\/2022\/07\/Griner.jpg?quality=85&amp;strip=all&amp;resize=850%2C478&quot;,&quot;pid_streaming_web_high&quot;:&quot;j44ToMIQFMg_&quot;,&quot;pid_streaming_web_medium&quot;:&quot;Aw30xJowAJbK&quot;,&quot;subtitle&quot;:&quot;&quot;,&quot;dfxp_url&quot;:&quot;&quot;,&quot;video_call_letter&quot;:&quot;NBCU LM VMS&quot;,&quot;video_captions&quot;:&quot;&quot;,&quot;video_id&quot;:&quot;2138976323906_307&quot;,&quot;video_length&quot;:&quot;238605&quot;,&quot;video_provider&quot;:&quot;mpx&quot;,&quot;short_video_excerpt&quot;:&quot;&quot;,&quot;mpx_download_pid_mobile_low&quot;:&quot;&quot;,&quot;pid_streaming_web_mobile_low&quot;:&quot;&quot;,&quot;mpx_download_pid_mobile_standard&quot;:&quot;&quot;,&quot;pid_streaming_mobile_standard&quot;:&quot;&quot;,&quot;media_pid&quot;:&quot;pAVL78O95le4&quot;,&quot;alleypack_schedule_unpublish&quot;:&quot;&quot;,&quot;feed_remote_id&quot;:&quot;mpx_2049680451559&quot;,&quot;feed_thumbnail_url&quot;:&quot;&quot;}"
	data-livestream="false"
	data-title="TIMELINE: Brittney Griner&#039;s Detainment in Russia"
	data-vidcid="1:11:2773025"
	data-vidurl="https://www.necn.com/news/national-international/timeline-brittney-griners-detainment-in-russia/2773025/"
			data-islead="true"
		data-catnames="{&quot;594891&quot;:&quot;News&quot;,&quot;193&quot;:&quot;U.S. &amp;amp; World&quot;}"
	data-tagnames="{&quot;694220&quot;:&quot;Brittney Griner&quot;,&quot;2526&quot;:&quot;Joe Biden&quot;,&quot;1044&quot;:&quot;Moscow&quot;,&quot;148897&quot;:&quot;Moscow court&quot;,&quot;705950&quot;:&quot;Phoenix Mercury&quot;,&quot;3146&quot;:&quot;Russia&quot;,&quot;725179&quot;:&quot;Russia-Ukraine Crisis&quot;,&quot;15&quot;:&quot;United States&quot;,&quot;628919&quot;:&quot;wnba&quot;}"
	data-customdata="{}"
			data-autoplay="true"
				data-cplay="true"
				data-msod-off="false"
	></div>
					<button class="video-flyout__dismiss">
						<span class="icon icon-times"></span>
					</button>
				</div>
			</div>
						<figcaption>
									<cite>NBCUniversal Media, LLC</cite>
				
															<div
							class="caption"
							data-react-component="NBCTruncate"
							data-maxlines="2"
							data-maxlinesmobile="4"
							data-readmore="Read more"
							data-text="&lt;p&gt;WNBA star Brittney Griner was arrested and detained in Russia on Feb. 17. Here is a timeline of events that led to her arrest and what has happened since.&lt;/p&gt;
"
							data-ellipsis="false">
						</div>
												</figcaption>
			</figure>
									<div class="article-content rich-text">
									
					
<p><em><a href="https://www.nbcsports.com/chicago/sports-world-reacts-brittney-griners-russian-prison-release?cid=Yahoo&amp;partner=ya4nbcs&amp;chrcontext=NECN">Sports world reacts to Brittney Griner’s Russian prison release</a> originally appeared on <a href="https://www.nbcsports.com/chicago?cid=MSN&amp;chrcontext=NECN">NBC Sports Chicago</a></em></p>

<p>Brittney Griner's 294-day detainment in Russia has finally <a href="https://www.nbcsports.com/bayarea/wnba-star-brittney-griner-freed-us-russia-prisoner-swap?chrcontext=NECN"><span><span><span><span><span><span><span><span>come to an end</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span>. </span></span></span></span></span></span></p>

<p><span><span><span><span><span><span>The 32-year-old WNBA star was released to the United States in a prisoner swap on Thursday, U.S. officials confirmed. This comes just four months after Griner was sentenced to nine years in prison for drug possession and smuggling charges.</span></span></span></span></span></span></p>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Moments ago I spoke to Brittney Griner.<br> <br>She is safe.<br>She is on a plane.<br>She is on her way home. <a href="https://t.co/FmHgfzrcDT">pic.twitter.com/FmHgfzrcDT</a></p>&mdash; President Biden (@POTUS) <a href="https://twitter.com/POTUS/status/1600841306560937986?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<div class="mobile-app-promotion">
	
<div class="wp-block-nbc-localized-block">
<blockquote class="featured-text">
	<strong><em>Get New England news, weather forecasts and entertainment stories to your inbox. <a href="https://www.necn.com/newsletters/?_osource=ed_npd_nbc_ne__newltrauto-signup-block">Sign up for NECN newsletters.</a></em></strong></blockquote>
</div>
</div>

<p><span><span><span><span><span><span>Griner – who, for years, had played in the off-season for the Russian women’s basketball team, the UMMC Ekaterinburg - was first detained in February and has remained in custody for seven months before finally being sentenced. But now, Griner is back in U.S. custody and on her way home to her hometown of Texas.</span></span></span></span></span></span></p>

<p><span><span><span><span><span><span>The sports world was filled with joy when the news of Griner's release broke and many took to social media to share their relief and excitement:</span></span></span></span></span></span></p>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Welcome home, Brittney Griner 🤍 <a href="https://t.co/ELtuqHiwXk">pic.twitter.com/ELtuqHiwXk</a></p>&mdash; USA Basketball (@usabasketball) <a href="https://twitter.com/usabasketball/status/1600868327093518336?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Celebrate Brittney Griner coming home to her family and now let’s get Marine Paul Whelan home too.</p>&mdash; Robert Griffin III (@RGIII) <a href="https://twitter.com/RGIII/status/1600866503158468608?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Welcome Home BG we owe u a very warm welcome. <a href="https://t.co/M0GoU3iEFw">https://t.co/M0GoU3iEFw</a></p>&mdash; Ebron85.eth (@Ebron85) <a href="https://twitter.com/Ebron85/status/1600845337161523200?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">BRITTNEY!!!!</p>&mdash; HADDY (@JIHADWARD17) <a href="https://twitter.com/JIHADWARD17/status/1600864987542876161?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Happy Brittany Griner is on her way home!!!!!</p>&mdash; Claressa Gwoat Shields (@Claressashields) <a href="https://twitter.com/Claressashields/status/1600849676005429251?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
https://twitter.com/POTUS?ref_src=twsrc%5Etfw"&gt;@POTUS</a> negotiated a "one-for-one" prisoner swap. <br><br>Thank you to President Biden, and to all those who worked so hard to secure her freedom.</p>— Billie Jean King (@BillieJeanKing) &lt;a href=&quot;https://twitter.com/BillieJeanKing/status/1600842280193216515
</div></figure>

<p><span><span><span><span><span><span>Griner's team, the Phoenix Mercury, and fellow teammates shared their reactions to her release:</span></span></span></span></span></span></p>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">No more days. She’s coming home 🧡 <a href="https://t.co/HsjbdPfdn5">pic.twitter.com/HsjbdPfdn5</a></p>&mdash; Phoenix Mercury (@PhoenixMercury) <a href="https://twitter.com/PhoenixMercury/status/1600876308988248064?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
https://twitter.com/hashtag/WEAREBG?src=hash&amp;ref_src=twsrc%5Etfw"&gt;#WEAREBG</a> <a href="https://t.co/Ltx4PEFqAK">https://t.co/Ltx4PEFqAK</a></p>— Brianna Turner (@_Breezy_Briii) &lt;a href=&quot;https://twitter.com/_Breezy_Briii/status/1600842465896198145
</div></figure>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">BG is coming home!!!!!🥺🥺🙏🏽🙏🏽🤍🤍</p>&mdash; Kia Nurse (@KayNurse11) <a href="https://twitter.com/KayNurse11/status/1600860488455233536?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Went from FREE BG to BG is FREE!! Won’t he do it! 🙌🏾</p>&mdash; Shey Peddy (@SheyP11) <a href="https://twitter.com/SheyP11/status/1600861334379315201?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Tears of joy today! And before Christmas? God is so good…welcome home BG!!!! We love you!🙏🏻😭❤️</p>&mdash; Alexandria Quigley (@alliequigley) <a href="https://twitter.com/alliequigley/status/1600865203889274880?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">YES BG🥺🤞🏾</p>&mdash; Kahleah Copper (@kahleahcopper) <a href="https://twitter.com/kahleahcopper/status/1600850108970516481?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">God is SO GOOD!! <a href="https://t.co/Sr4RB6bP6b">https://t.co/Sr4RB6bP6b</a></p>&mdash; Dana Evans (@Danaaakianaaa) <a href="https://twitter.com/Danaaakianaaa/status/1600848963317661697?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<p><span><span><span><span><span><span>Other WNBA stars also added their support for Griner's release:</span></span></span></span></span></span></p>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">BG is FREE!!! 294 days and she is coming home!!! 😭🤍🙏🏻❤️</p>&mdash; Breanna Stewart (@breannastewart) <a href="https://twitter.com/breannastewart/status/1600843953644834817?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">How bout Christmas miracles! God Is good! I’m so happy right now! BG free!!!! 🙌🏾😊🥹</p>&mdash; Jonquel Jones (@jus242) <a href="https://twitter.com/jus242/status/1600843938784374784?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="in" dir="ltr">BG is Free ❤️ <a href="https://t.co/lsqsPJjnGI">https://t.co/lsqsPJjnGI</a></p>&mdash; Sue Bird (@S10Bird) <a href="https://twitter.com/S10Bird/status/1600862788343463937?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<p><span><span><span><span><span><span>American basketball Hall of Fame player and coach Dawn Staley was one of Griner's biggest supporters and heavily advocated for her release over the past months:</span></span></span></span></span></span></p>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
https://twitter.com/brittneygriner?ref_src=twsrc%5Etfw"&gt;@brittneygriner</a> is home!I love you BG!</p>— dawnstaley (@dawnstaley) &lt;a href=&quot;https://twitter.com/dawnstaley/status/1600839912466841602
</div></figure>

<p><span><span><span><span><span><span>Griner's wife Cherelle spoke at the White House following the news of Griner's release.</span></span></span></span></span></span></p>

<p><span><span><span><span><span><span>“For the last nine months you all have been so privy for one of the darkest moments of my life,” Cherelle said at the White House. “Today my family is whole, but as you're all aware, there are so many families that are not whole. [Brittney] and I will remain committed to the work of getting every American home, including Paul.”</span></span></span></span></span></span></p>
<div class="recirc-module">
	<h3 class="recirc__heading">Sports</h3>
	<p class="recirc__subheading">Patriots, Red Sox, Bruins, Celtics and more </p>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="MLB Free Agent Tracker: Full List of 2022-23 Offseason Signings" href="https://www.necn.com/news/sports/mlb-free-agent-tracker-full-list-of-2022-23-offseason-signings/2885761/">
														<img alt="" class="post__image" srcset="https://media.necn.com/2022/12/web-221207-aaron-judge-point.jpg?quality=85&amp;strip=all&amp;fit=6883%2C3871&amp;w=130&amp;h=73&amp;crop=1 130w, https://media.necn.com/2022/12/web-221207-aaron-judge-point.jpg?quality=85&amp;strip=all&amp;fit=6883%2C3871&amp;w=170&amp;h=96&amp;crop=1 170w, https://media.necn.com/2022/12/web-221207-aaron-judge-point.jpg?quality=85&amp;strip=all&amp;fit=6883%2C3871&amp;w=210&amp;h=118&amp;crop=1 210w, https://media.necn.com/2022/12/web-221207-aaron-judge-point.jpg?quality=85&amp;strip=all&amp;fit=6883%2C3871&amp;w=250&amp;h=141&amp;crop=1 250w, https://media.necn.com/2022/12/web-221207-aaron-judge-point.jpg?quality=85&amp;strip=all&amp;fit=6883%2C3871&amp;w=290&amp;h=163&amp;crop=1 290w, https://media.necn.com/2022/12/web-221207-aaron-judge-point.jpg?quality=85&amp;strip=all&amp;fit=6883%2C3871&amp;w=330&amp;h=186&amp;crop=1 330w" src="https://media.necn.com/2022/12/web-221207-aaron-judge-point.jpg?quality=85&#038;strip=all" loading="lazy" sizes="(min-width: 768px) 166px, 124px" />
						</a>

						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="MLB Free Agency" class="post__tag" href="https://www.necn.com/tag/mlb-free-agency/">MLB Free Agency</a>
																			<span class="post__date post__date--has-category">
								Dec 7							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="MLB Free Agent Tracker: Full List of 2022-23 Offseason Signings" class="post__title--link" href="https://www.necn.com/news/sports/mlb-free-agent-tracker-full-list-of-2022-23-offseason-signings/2885761/">
								MLB Free Agent Tracker: Full List of 2022-23 Offseason Signings							</a>
						</h3>
									</div>
			</div>
		</div>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="How to Watch Brazil Vs. Croatia in 2022 World Cup Quarterfinals" href="https://www.necn.com/news/sports/world-cup-2022/how-to-watch-brazil-vs-croatia-in-2022-world-cup-quarterfinals/2886531/">
														<img alt="" class="post__image" srcset="https://media.necn.com/2022/12/web-221205-neymar-vini-jr.jpg?quality=85&amp;strip=all&amp;fit=4000%2C2250&amp;w=130&amp;h=73&amp;crop=1 130w, https://media.necn.com/2022/12/web-221205-neymar-vini-jr.jpg?quality=85&amp;strip=all&amp;fit=4000%2C2250&amp;w=170&amp;h=96&amp;crop=1 170w, https://media.necn.com/2022/12/web-221205-neymar-vini-jr.jpg?quality=85&amp;strip=all&amp;fit=4000%2C2250&amp;w=210&amp;h=118&amp;crop=1 210w, https://media.necn.com/2022/12/web-221205-neymar-vini-jr.jpg?quality=85&amp;strip=all&amp;fit=4000%2C2250&amp;w=250&amp;h=141&amp;crop=1 250w, https://media.necn.com/2022/12/web-221205-neymar-vini-jr.jpg?quality=85&amp;strip=all&amp;fit=4000%2C2250&amp;w=290&amp;h=163&amp;crop=1 290w, https://media.necn.com/2022/12/web-221205-neymar-vini-jr.jpg?quality=85&amp;strip=all&amp;fit=4000%2C2250&amp;w=330&amp;h=186&amp;crop=1 330w" src="https://media.necn.com/2022/12/web-221205-neymar-vini-jr.jpg?quality=85&#038;strip=all" loading="lazy" sizes="(min-width: 768px) 166px, 124px" />
						</a>

													<span class="format-icon format-icon--video"></span>
						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="Brazil" class="post__tag" href="https://www.necn.com/tag/brazil/">Brazil</a>
																			<span class="post__date post__date--has-category">
								2 hours ago							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="How to Watch Brazil Vs. Croatia in 2022 World Cup Quarterfinals" class="post__title--link" href="https://www.necn.com/news/sports/world-cup-2022/how-to-watch-brazil-vs-croatia-in-2022-world-cup-quarterfinals/2886531/">
								How to Watch Brazil Vs. Croatia in 2022 World Cup Quarterfinals							</a>
						</h3>
									</div>
			</div>
		</div>
	</div>

<p><span><span><span><span><span><span>The “Paul” Cherelle refers to is Paul Whelan, a U.S. citizen and former Marine detained at a Moscow hotel in December 2018 and arrested on espionage charges. President Biden has attempted to include Whelan in the swap but it was not accepted by the Russian government.</span></span></span></span></span></span></p>

<p><span><span><span><span><span><span>“We never forgot about Brittney. We haven’t forgotten about Paul Whelan,” Biden said about Whelan. “While we have not yet succeeded in securing Paul’s release, we have not given up. We will never give up.”</span></span></span></span></span></span></p>

<p><span><span><span><span><span><span>Dallas Cowboys linebacker Micah Parsons took to Twitter to speak on Griner's release and his shock that Whelan was not released as well, but it was met with disappointment from many on social media:</span></span></span></span></span></span></p>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Wait nah!! We left a marine?!! Hell nah <a href="https://t.co/3AeQx8K9OZ">https://t.co/3AeQx8K9OZ</a></p>&mdash; Micah Parsons (@MicahhParsons11) <a href="https://twitter.com/MicahhParsons11/status/1600839683407126530?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<p><span><span><span><span><span><span>He later cleared up his previous tweet and added that he is happy Griner is home but his initial tweet was tweeted "out of emotion" for his family that has served.</span></span></span></span></span></span></p>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Just spoke to some people that I respect and trust. I should have been more educated on the topic and not tweeted out of emotion for my family and other who have served. For that I apologize. Also if what I’m told about the attempts to bring Ret Marine Paul Whelan home are true</p>&mdash; Micah Parsons (@MicahhParsons11) <a href="https://twitter.com/MicahhParsons11/status/1600870646086393856?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<p><span><span><span><span><span><span>Many sports analysts tweeted their support for Griner as well:</span></span></span></span></span></span></p>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">THIS IS AMAZING!!!!!!<br><br>WELCOME HOME BG! <a href="https://t.co/oPdP64ub7Z">https://t.co/oPdP64ub7Z</a></p>&mdash; Jemele Hill (@jemelehill) <a href="https://twitter.com/jemelehill/status/1600841624954601479?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">The story is still developing but YES. The headline “WNBA star Brittney Griner released” is all we ever wanted to hear. WE LOVE YOU BG. WE LOVE YOU! <a href="https://t.co/eQQQRJTHUl">pic.twitter.com/eQQQRJTHUl</a></p>&mdash; Arielle (Ari) Chambers (@ariivory) <a href="https://twitter.com/ariivory/status/1600841306107875330?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Beautiful news for us all to wake up to. BG back where she belongs. ♥️ <a href="https://t.co/e7p6zKkHyN">https://t.co/e7p6zKkHyN</a></p>&mdash; Taylor Rooks (@TaylorRooks) <a href="https://twitter.com/TaylorRooks/status/1600879658454507520?ref_src=twsrc%5Etfw">December 8, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<p><span><span><span><span><span><span>Vice President Kamala Harris and former President Barack Obama also added their thoughts:</span></span></span></span></span></span></p>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
https://twitter.com/POTUS?ref_src=twsrc%5Etfw"&gt;@POTUS</a>â commitment to bring home every U.S. citizen wrongfully detained anywhere in the world.</p>— Vice President Kamala Harris (@VP) &lt;a href=&quot;https://twitter.com/VP/status/1600862766902005760
</div></figure>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
https://twitter.com/POTUS?ref_src=twsrc%5Etfw"&gt;@POTUS</a> and his administration for the difficult diplomatic work involved to make it happen. Weâre looking forward to having Brittney back home. <a href="https://t.co/G5yKliRoxd">https://t.co/G5yKliRoxd</a></p>— Barack Obama (@BarackObama) &lt;a href=&quot;https://twitter.com/BarackObama/status/1600870440591036416
</div></figure>

<p><span><span><span><span><span><span>There currently aren’t plans as to whether Griner will return to UMMC Ekaterinburg, but the focus is currently on her safe return home.</span></span></span></span></span></span> </p>

									</div>
											<div class="article-copyright">Copyright RSN</div>
				<div class="article-footer">
			<div class="article-tags">
	<h4 class="article-tags__heading">This article tagged under:</h4>
	<a class="article-tags__tag" href="https://www.necn.com/tag/brittney-griner/">Brittney Griner</a></div>
			<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.necn.com%2Fnews%2Fsports%2Fsports-world-reacts-to-brittney-griners-russian-prison-release%2F2886628%2F&#038;Sports%20World%20Reacts%20to%20Brittney%20Griner%27s%20Russian%20Prison%20Release?_osource=db_npd_nbc_necn_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Sports%20World%20Reacts%20to%20Brittney%20Griner%27s%20Russian%20Prison%20Release&#038;url=https%3A%2F%2Fwww.necn.com%2Fnews%2Fsports%2Fsports-world-reacts-to-brittney-griners-russian-prison-release%2F2886628%2F?_osource=db_npd_nbc_necn_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=Sports%20World%20Reacts%20to%20Brittney%20Griner%27s%20Russian%20Prison%20Release%0D%0A%0D%0Ahttps%3A%2F%2Fwww.necn.com%2Fnews%2Fsports%2Fsports-world-reacts-to-brittney-griners-russian-prison-release%2F2886628%2F?_osource=db_npd_nbc_necn_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
			<a href="#" data-service="comments">
			<span class="icon icon-comment-alt"></span>
		</a>
	</div>
		</div>
					<div id="div-gpt-ad-mobilemultibox_belowarticle" class="widget_ad_layers_ad_widget gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_belowarticle', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script>		<div>
			<div id="taboola-below-article-thumbnails"></div>
		<script type="text/javascript">
			if (document.cookie.indexOf("scroll0=") < 0) {
				window._taboola = window._taboola || [];
				_taboola.push({
					article: 'auto',
					url: ''
				});
								_taboola.push({
					mode: 'thumbnails-a',
					container: 'taboola-below-article-thumbnails',
					placement: 'Below Article Thumbnails',
					target_type: 'mix'
				});
								_taboola.push({
					flush: true
				});
			};
		</script>
				<div id="mobile-native-below-article"></div>
		<script type="text/javascript">
			var isMobile = window.matchMedia('screen and (max-width: 767px)').matches;
			/** scroll cookie for scroll.com **/
			if (document.cookie.indexOf("scroll0=") < 0 && isMobile) {
				window._taboola = window._taboola || [];
				_taboola.push({
					mode: 'thumbs-feed-03-mobile',
					container: 'mobile-native-below-article',
					placement: 'Below Article Thumbnails - Fallback',
					target_type: 'text'
				});
			};
		</script>
			</div><!-- .taboola-container -->
				</div>
		</div>
		<div class="section-content--secondary">
			<aside class="sidebar article-sidebar">
						<section id="nbc_most_popular-2" class="widget widget_nbc_most_popular">		<div class="most-popular__container">
			<div class="most-popular__header">
				<h3 class="widget-title">Trending Stories</h3>
				<div class="sponsored-ad-container">
					<div id="div-gpt-ad-logo_trending" class="sponsored-ad-unit gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_trending', format: 'logo', targeting: {"slot":"logo","pos":"logo"} });
			</script>				</div>
			</div>
			<ul class="most-popular__posts-list">
														<li class="most-popular__post">
						<div class="post__image__wrap">
							<a
								data-lpos="most-popular"
								data-lid="Kirstie Alley Was Diagnosed With Colon Cancer: Symptoms to Know"
								href="https://www.necn.com/news/national-international/kirstie-alley-was-diagnosed-with-colon-cancer-symptoms-to-know/2886091/"
							>
								<img
									class="post__image"
									src="https://media.necn.com/2022/12/GettyImages-127632082.jpg?quality=85&#038;strip=all&#038;resize=100%2C56"
									alt="Kirstie Alley Was Diagnosed With Colon Cancer: Symptoms to Know"
									loading="lazy"
								/>
							</a>
						</div>
						<div class="post__content">
															<h4 class="post__category">
									<a
										class="post__category-link"
										data-lpos="most-popular"
										data-lid="Celebrity News"
										href="https://www.necn.com/tag/celebrity-news/"
									>
										Celebrity News									</a>
								</h4>
														<div class="post__title">
								<a
									class="post__category-link"
									data-lpos="most-popular"
									data-lid="Kirstie Alley Was Diagnosed With Colon Cancer: Symptoms to Know"
									href="https://www.necn.com/news/national-international/kirstie-alley-was-diagnosed-with-colon-cancer-symptoms-to-know/2886091/"
								>
									Kirstie Alley Was Diagnosed With Colon Cancer: Symptoms to Know								</a>
							</div>
													</div>
					</li>
														<li class="most-popular__post">
						<div class="post__image__wrap">
							<a
								data-lpos="most-popular"
								data-lid="Woman Arrested for Theft After Failing to Deliver Packages"
								href="https://www.necn.com/news/national-international/woman-arrested-for-theft-after-failing-to-deliver-packages/2886512/"
							>
								<img
									class="post__image"
									src="https://media.necn.com/2021/04/106876780-1619808574333-gettyimages-1229053553-AMAZON_PRIME_DAY.jpeg?quality=85&#038;strip=all&#038;resize=100%2C56"
									alt="Woman Arrested for Theft After Failing to Deliver Packages"
									loading="lazy"
								/>
							</a>
						</div>
						<div class="post__content">
															<h4 class="post__category">
									<a
										class="post__category-link"
										data-lpos="most-popular"
										data-lid="delivery driver"
										href="https://www.necn.com/tag/delivery-driver/"
									>
										delivery driver									</a>
								</h4>
														<div class="post__title">
								<a
									class="post__category-link"
									data-lpos="most-popular"
									data-lid="Woman Arrested for Theft After Failing to Deliver Packages"
									href="https://www.necn.com/news/national-international/woman-arrested-for-theft-after-failing-to-deliver-packages/2886512/"
								>
									Woman Arrested for Theft After Failing to Deliver Packages								</a>
							</div>
													</div>
					</li>
														<li class="most-popular__post">
						<div class="post__image__wrap">
							<a
								data-lpos="most-popular"
								data-lid="College Student Accused of Smashing Train Car Window"
								href="https://www.necn.com/news/national-international/student-summonsed-for-smashing-train-car-window/2886621/"
							>
								<img
									class="post__image"
									src="https://media.necn.com/2022/12/MBTA-Vandalism-Pic.jpeg?quality=85&#038;strip=all&#038;resize=100%2C56"
									alt="College Student Accused of Smashing Train Car Window"
									loading="lazy"
								/>
							</a>
						</div>
						<div class="post__content">
															<h4 class="post__category">
									<a
										class="post__category-link"
										data-lpos="most-popular"
										data-lid="mbta"
										href="https://www.necn.com/tag/mbta/"
									>
										mbta									</a>
								</h4>
														<div class="post__title">
								<a
									class="post__category-link"
									data-lpos="most-popular"
									data-lid="College Student Accused of Smashing Train Car Window"
									href="https://www.necn.com/news/national-international/student-summonsed-for-smashing-train-car-window/2886621/"
								>
									College Student Accused of Smashing Train Car Window								</a>
							</div>
													</div>
					</li>
														<li class="most-popular__post">
						<div class="post__image__wrap">
							<a
								data-lpos="most-popular"
								data-lid="Celine Dion Reveals She Has Stiff-Person Syndrome in Emotional Video"
								href="https://www.necn.com/entertainment/entertainment-news/celine-dion-reveals-she-has-stiff-person-syndrome-in-emotional-video/2886497/"
							>
								<img
									class="post__image"
									src="https://media.necn.com/2022/12/GettyImages-1159763690.jpg?quality=85&#038;strip=all&#038;resize=100%2C56"
									alt="Celine Dion Reveals She Has Stiff-Person Syndrome in Emotional Video"
									loading="lazy"
								/>
							</a>
						</div>
						<div class="post__content">
															<h4 class="post__category">
									<a
										class="post__category-link"
										data-lpos="most-popular"
										data-lid="Celine Dion"
										href="https://www.necn.com/tag/celine-dion/"
									>
										Celine Dion									</a>
								</h4>
														<div class="post__title">
								<a
									class="post__category-link"
									data-lpos="most-popular"
									data-lid="Celine Dion Reveals She Has Stiff-Person Syndrome in Emotional Video"
									href="https://www.necn.com/entertainment/entertainment-news/celine-dion-reveals-she-has-stiff-person-syndrome-in-emotional-video/2886497/"
								>
									Celine Dion Reveals She Has Stiff-Person Syndrome in Emotional Video								</a>
							</div>
													</div>
					</li>
													<li class="most-popular__post taboola__post">
						<div id="taboola-right-rail-thumbnails---fallback"></div>
					</li>
					<script>
						try {
							window._taboola = window._taboola || [];
							_taboola.push({
								listenTo: 'nocontent',
								placement: 'Right Rail Thumbnails - Fallback',
								handle: function() {
									document.querySelector('.most-popular__post:nth-of-type(5)').remove();
								}
							});
							_taboola.push({
								mode: 'thumbnails-a-right-rail',
								container: 'taboola-right-rail-thumbnails---fallback',
								placement: 'Right Rail Thumbnails - Fallback',
								target_type: 'mix',
								flush: true,
							});
						} catch (e) {
							console.error(e);
						}
					</script>
							</ul>
		</div>
		</section><section id="ad_layers_ad_widget-2" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-topbox_208" class=" gpt-topbox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbox_208', format: 'topbox', targeting: {"slot":"topbox","pos":"topbox"} });
			</script></section><section id="nbc_weather_widget-3" class="widget widget_nbc_weather_widget">		<div class="nbc-weather-widget">
			<div class="nbc_owned_television_stations_weather_iframe">
	<h3>Weather Forecast</h3><div data-react-component="IframeLocation" data-market-name="Boston, MA"></div>
	<a class="weather-module__conditions" href="https://www.necn.com/weather/">
		<div data-react-component="IframeConditions" data-location="2201"></div>
	</a>
		<div class="widget_sponsor">
		<div id="div-gpt-ad-logo_weather_635" class="sponsored-ad-unit gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_weather_635', format: 'logo', targeting: {"module":"weather","slot":"logo","pos":"logo"} });
			</script>	</div>
</div>
		</div>
		</section><section id="ad_layers_ad_widget-6" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-bottombox_113" class=" gpt-bottombox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'bottombox_113', format: 'bottombox', targeting: {"slot":"bottombox","pos":"bottombox"} });
			</script></section><section id="ad_layers_ad_widget-12" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-interstitial_106" class=" gpt-interstitial" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'interstitial_106', format: 'interstitial', targeting: {"slot":"interstitial","pos":"interstitial"} });
			</script></section><section id="ad_layers_ad_widget-13" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilebackstage_961" class=" gpt-mobilebackstage" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilebackstage_961', format: 'mobilebackstage', targeting: {"slot":"mobilebackstage","pos":"mobilebackstage"} });
			</script></section><section id="nbc_newsletter-2" class="widget widget_nbc_newsletter"><div class="newsletter-widget"
				data-react-component="NewsletterWidget"
				data-title="Subscribe to our Newsletters"
				data-description="Sign up to receive breaking news alerts in your inbox."
				data-newsletter-id="NECN_BreakingNews"
				data-footer-signup=""
				data-privacy-link="http://www.nbcuniversal.com/privacy/"
				data-newsletter-link=""
				data-nonce="681be8fb8b"
				data-show-terms-box=""
				data-use-newsletter-ids=""
				data-newsletter-ids="[]"
				></div></section>			</aside>
		</div>
	</div>
</article>

			</main>
		</div>

		
	</div><!-- #content -->
	
<footer role="contentinfo" class="site-footer">
	<div class="site-footer__wrapper">
		<div class="site-footer__identity">
							<a href="https://www.necn.com/" class="site-footer__logo">
					<img
						src="https://media.necn.com/2019/09/NECN_On_Light-@3x-1.png?fit=354%2C120&#038;quality=85&#038;strip=all"
						alt="NECN"
						loading="lazy"
					/>
				</a>
			
			
			<ul class="site-footer__social-list">
				
									<li class="site-footer__social-list-item facebook">
						<a href="http://www.facebook.com/necntv" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Facebook</span>
							<span class="icon icon-facebook-f"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item twitter">
						<a href="https://twitter.com/NECN" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Twitter</span>
							<span class="icon icon-twitter"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item instagram">
						<a href="https://instagram.com/necntv" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Instagram</span>
							<span class="icon icon-instagram"></span>
						</a>
					</li>
							</ul>
		</div>

		<ul id="menu-footer" class="footer-menu site-footer__menu-primary"><li id="menu-item-2183207" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2183207"><a href="/investigations/submit-tip/">Submit Tips for Investigations</a></li>
<li id="menu-item-2158151" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2158151"><a href="https://www.necn.com/contact-us/">Contact Us</a></li>
<li id="menu-item-2183206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2183206"><a href="https://www.necn.com/newsletters/">Newsletters</a></li>
</ul><ul id="menu-primary" class="footer-menu-secondary site-footer__menu-secondary"><li id="menu-item-2153046" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2153046"><a href="https://www.necn.com/send-feedback/">Send Feedback</a></li>
<li id="menu-item-2153048" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2153048"><a href="https://www.necn.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-2153041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2153041"><a target="_blank" rel="noopener" href="https://www.nbcuniversal.com/privacy/?brandA=Owned_Stations&#038;intake=NECN">Privacy Policy</a></li>
<li id="menu-item-2153043" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2153043"><a id="ot-sdk-btn" class="ot-sdk-show-settings">Cookie Settings</a></li>
<li id="menu-item-2153045" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2153045"><a href="https://together.nbcuni.com/advertise/?utm_source=necn&#038;utm_medium=referral&#038;utm_campaign=property_ad_pages">Advertise with us</a></li>
<li id="menu-item-2300877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2300877"><a href="https://www.nbcuniversal.com/privacy/california-consumer-privacy-act?intake=NECN">CA Notice</a></li>
<li id="menu-item-2153044" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2153044"><a target="_blank" rel="noopener" href="https://www.nbcuniversal.com/privacy/cookies#accordionheader2">Ad Choices</a></li>
</ul>
				<div class="site-footer__corporate">
			
			<span class="site-footer__corporate-copyright">
				Copyright © 2022 NBCUniversal Media, LLC. All rights reserved			</span>
		</div>
	</div><!-- wrapper -->
</footer><!-- #colophon -->
</div><!-- #page -->

			<script
				src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js"
				id="privacyCookie"
				type="text/javascript"
				charset="UTF-8"
				ccpa-opt-out-ids="dummy"
				ccpa-opt-out-geo="US"
				ccpa-opt-out-lspa="false"
			>
			</script>
			<script
				src="https://cdn.cookielaw.org/consent/850f2523-ecb3-4f4a-95a4-203ea0b94837/otSDKStub.js"
				data-document-language="true"
				type="text/javascript"
				charset="UTF-8"
				data-domain-script="850f2523-ecb3-4f4a-95a4-203ea0b94837"
									integrity="sha384-ZiegGStHtw2zXX+Hd9IX8tTxIDTMb8FwlLNdjP0V2aK9ddQu9SYkgu3Q0U+t6ZgN"
					crossorigin="anonymous"
							>
			</script>
				<script type="text/javascript">
	(function() {
		var _sf_async_config      = window._sf_async_config = window._sf_async_config || {};
		_sf_async_config.domain   = "necn.com";
		_sf_async_config.uid      = 15527;
		_sf_async_config.sections = "news, sports";
		_sf_async_config.authors  = "Marsha Green";
		_sf_async_config.title    = "Sports World Reacts to Brittney Griner's Russian Prison Release";
		_sf_async_config.path     = "necn.com\/news\/sports\/sports-world-reacts-to-brittney-griners-russian-prison-release\/2886628\/";
		
		var e = document.createElement('script');
		var n = document.getElementsByTagName('script')[0];
		e.type = 'text/javascript';
		e.async = true;
		e.src = '//static.chartbeat.com/js/chartbeat.js';
		n.parentNode.insertBefore(e, n);
	})();
	</script>
			<!-- Begin comScore Tag -->
		<script>
			(function() {
				var usPrivacyCookie = new RegExp("usprivacy=([^;]+)").exec(document.cookie),
					usPrivacy = null !== usPrivacyCookie ? unescape(usPrivacyCookie[1]) : undefined,
					csUCFR = '1YYN' === usPrivacy ? '0': '',
					s = document.createElement("script"),
					el = document.getElementsByTagName("script")[0];

				window._comscore = window._comscore || [];

				window._comscore.push({
					c1: "2",
					c2: "6035083",
					cs_ucfr: csUCFR,
				});

				s.async = true;
				s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
				el.parentNode.insertBefore(s, el);
			})();
		</script>
		<noscript>
			<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035083&cv=2.0&cj=1" />
		</noscript>
		<!-- End comScore Tag -->
				<script type="text/javascript">
		(function() {
			var loaderUrl, scriptType;
			window._taboola = window._taboola || [];
			window._newsroom = window._newsroom || [];
			const taboola_config = {};

			taboola_config[decodeURIComponent( 'article' )] = decodeURIComponent( '2886628' );
			taboola_config['url'] = document.URL;
			taboola_config['tracking'] = '_osource=taboola-recirc';
			_taboola.push(taboola_config);

						scriptType = 'tb_loader_script';
			loaderUrl = 'https://cdn.taboola.com/libtrc/nbcots-network/loader.js';
			
			!function (e, f, u, i) {
				e.async = 1;
				e.src = u;
				e.id = i;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			loaderUrl,
			scriptType);

			!function (e, f, u) {
				e.async = 1;
				e.src = u;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			"\/\/c2.taboola.com\/nr\/nbcots-necn\/newsroom.js");
		}());
		</script>
				<div class="facebook-comments">
			<button class="facebook-comments__close"><span class="icon icon-chevron-left"></span> Back to Article</button>
			<div class="fb-comments" data-href="https://www.necn.com/news/sports/sports-world-reacts-to-brittney-griners-russian-prison-release/2886628/" data-width="100%"></div>
		</div>
		<div class="flyout-nav" data-component="flyoutNav">
	<button class="flyout-nav__close"><span class="icon icon-times"></span> <span class="screen-reader-text">Close Menu</span></button>
	<div class="flyout-nav__logo">
		<a href="https://www.necn.com/">
					<img
						src="https://media.necn.com/2019/09/NECN_On_Light-@3x-1.png?fit=354%2C120&#038;quality=85&#038;strip=all"
						alt="NECN"
					/>
		</a>
	</div>
	<div class="flyout-nav__search">
<form class="search-form" role="search" method="get" action="https://www.necn.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input class="search-form-input" type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
</div>
	<div class="flyout-nav__menu">
		<div class="flyout-nav__menu--upper">
							<a data-lid="Meet the Team" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="https://www.necn.com/contact-us/">
					Meet the Team				</a>
							<a data-lid="Coronavirus Pandemic" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/coronavirus/">
					Coronavirus Pandemic				</a>
							<a data-lid="Local" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/local/">
					Local				</a>
							<a data-lid="Massachusetts" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/massachusetts/">
					Massachusetts				</a>
							<a data-lid="Connecticut" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/connecticut/">
					Connecticut				</a>
							<a data-lid="Maine" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/maine/">
					Maine				</a>
							<a data-lid="New Hampshire" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/new-hampshire/">
					New Hampshire				</a>
							<a data-lid="Rhode Island" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/rhode-island/">
					Rhode Island				</a>
							<a data-lid="Vermont" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/vermont/">
					Vermont				</a>
							<a data-lid="Weather" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/weather/">
					Weather				</a>
							<a data-lid="Maps &amp; Radar" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/maps/">
					Maps &amp; Radar				</a>
							<a data-lid="Weather Alerts" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/severe-weather-alerts/">
					Weather Alerts				</a>
							<a data-lid="School Closing Alerts" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.necn.com/weather/school-closings/">
					School Closing Alerts				</a>
							<a data-lid="Sports" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/sports/">
					Sports				</a>
							<a data-lid="Traffic" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/traffic/">
					Traffic				</a>
							<a data-lid="Business" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/business/">
					Business				</a>
							<a data-lid="Virtual Connection" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.necn.com/news/national-international/virtual-connection-community-services-for-you-and-your-family-during-the-coronavirus-pandemic/2251566/">
					Virtual Connection				</a>
							<a data-lid="This Week in Business" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/business/twib/">
					This Week in Business				</a>
							<a data-lid="Chief Execs Club" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/chief-execs-club/">
					Chief Execs Club				</a>
							<a data-lid="Ceo Corner" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/business/ceo-corner/">
					Ceo Corner				</a>
					</div>
		<div class="flyout-nav__menu--lower">
							<a data-lid="TV Listings" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.necn.com/live/">
					TV Listings				</a>
							<a data-lid="Submit Photos and Video" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/ugc/">
					Submit Photos and Video				</a>
							<a data-lid="Newsletters" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/newsletters/">
					Newsletters				</a>
							<a data-lid="Our Apps" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/products/">
					Our Apps				</a>
							<a data-lid="Cozi TV" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://cozitv.com/">
					Cozi TV				</a>
					</div>
	</div>
	<div class="flyout-nav__social">
		<h4 class="flyout-nav__social-heading">Follow Us</h4>
		<ul class="flyout-nav__social-list">
			
							<li class="site-footer__social-list-item facebook" rel="noopener noreferrer">
					<a href="http://www.facebook.com/necntv" target="_blank">
						<span class="screen-reader-text">Facebook</span>
						<span class="icon icon-facebook-f"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item twitter" rel="noopener noreferrer">
					<a href="https://twitter.com/NECN" target="_blank">
						<span class="screen-reader-text">Twitter</span>
						<span class="icon icon-twitter"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item instagram" rel="noopener noreferrer">
					<a href="https://instagram.com/necntv" target="_blank">
						<span class="screen-reader-text">Instagram</span>
						<span class="icon icon-instagram"></span>
					</a>
				</li>
					</ul>
	</div>
</div>
<a class="flyout-contact-button" data-lid="Contact Us" data-lpos="hamburger-menu"
			href="/contact-us/"
	>
	Contact Us</a>
<link rel='stylesheet' id='nbc-most-popular-css'  href='https://www.necn.com/wp-content/themes/nbc-station/client/build/css/mostPopular.f58524ab569a30c1fff2.min.css?ver=1.0.2' media='all' />
<link rel='stylesheet' id='nbc-forms-css'  href='https://www.necn.com/wp-content/themes/nbc-station/client/build/css/forms.0c69dfbaf447a32a1b47.min.css?ver=1.0.2' media='all' />
<link rel='stylesheet' id='newsletter-widget-css'  href='https://www.necn.com/wp-content/themes/nbc-station/client/build/css/newsletterWidget.4ac4dcd7ae22a178c5a3.min.css?ver=1.0.2' media='all' />
<link rel='stylesheet' id='nbc-footer-css'  href='https://www.necn.com/wp-content/themes/nbc-station/client/build/css/footer.20b28205d164f6506379.min.css?ver=1.0.2' media='all' />
<link rel='stylesheet' id='nbc-flyout-nav-css'  href='https://www.necn.com/wp-content/themes/nbc-station/client/build/css/flyoutNav.79cc3b49e53bd7cab3d1.min.css?ver=1.0.2' media='all' />
<link rel='stylesheet' id='nbc-weather-icons-css'  href='https://www.necn.com/wp-content/themes/nbc-station/client/build/css/weatherIcons.04ad80f6dd854170fd37.min.css?ver=1.0.2' media='all' />
<link rel='stylesheet' id='pdk-css'  href='https://www.necn.com/wp-content/themes/nbc-station/static/css/player_smooth.css?ver=1.0.2' media='all' />
<script defer src='https://z.moatads.com/nbcuyieldheader7581548001/moatheader.js?ver=1.0.0' id='moat-js'></script>
<script src='https://www.necn.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.7' id='regenerator-runtime-js'></script>
<script src='https://www.necn.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script src='https://www.necn.com/wp-includes/js/dist/hooks.min.js?ver=a7edae857aab69d69fa10d5aef23a5de' id='wp-hooks-js'></script>
<script src='https://www.necn.com/wp-includes/js/dist/i18n.min.js?ver=5f1269854226b4dd90450db411a12b79' id='wp-i18n-js'></script>
<script id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script src='https://www.necn.com/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.19' id='lodash-js'></script>
<script id='lodash-js-after'>
window.lodash = _.noConflict();
</script>
<script src='https://www.necn.com/wp-includes/js/dist/url.min.js?ver=9e623834b7667b522230408f099fc05f' id='wp-url-js'></script>
<script id='wp-api-fetch-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script src='https://www.necn.com/wp-includes/js/dist/api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df' id='wp-api-fetch-js'></script>
<script id='wp-api-fetch-js-after'>
wp.apiFetch.use( wp.apiFetch.createRootURLMiddleware( "https://www.necn.com/wp-json/" ) );
wp.apiFetch.nonceMiddleware = wp.apiFetch.createNonceMiddleware( "681be8fb8b" );
wp.apiFetch.use( wp.apiFetch.nonceMiddleware );
wp.apiFetch.use( wp.apiFetch.mediaUploadMiddleware );
wp.apiFetch.nonceEndpoint = "https://www.necn.com/wp-admin/admin-ajax.php?action=rest-nonce";
wp.apiFetch.use( wp.apiFetch.createPreloadingMiddleware( {"\/nbc\/v1\/weather-alerts":{"body":[],"headers":[]}} ) );
</script>
<script src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/common.84c9932d5323c8157407.bundle.min.js' id='nbc-common-js'></script>
<script async src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/global.5619476906892270277d.bundle.min.js' id='nbc-global-js'></script>
<script async src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/article.be9dd6376e29c459a09d.bundle.min.js' id='nbc-article-js'></script>
<script src='https://www.necn.com/wp-content/themes/nbc-station/static/js/zepto.min.js?ver=1.0.2' id='zepto-js'></script>
<script src='https://www.necn.com/wp-content/themes/nbc-station/static/js/player.6.1.3.js?ver=1.0.2' id='pdk-js'></script>
<script async src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/videoPlayer.7467d724b220d207aaa8.bundle.min.js' id='nbc-video-player-js'></script>
<script async src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/electionsBlock.72997dd8cd85ad133fdc.bundle.min.js' id='nbc-elections-block-js'></script>
<script async src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/flyoutNav.f7b6eab132d19d0ea6aa.bundle.min.js' id='nbc-flyout-nav-js'></script>
<script async src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/articleContent.a15baabf937383921d67.bundle.min.js' id='nbc-article-content-js'></script>
<script async src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/weatherConditions.a03d9a5aa4bb98e8cbd8.bundle.min.js' id='nbc-weather-conditions-js'></script>
<script async src='https://www.necn.com/wp-content/themes/nbc-station/client/build/js/webVitals.ea745b44ba0695d3b78f.bundle.min.js' id='nbc-web-vitals-js'></script>
<script defer src='https://assets.adobedtm.com/a2ef59fba8e9/3ba8c6b033ff/launch-6a742ce4ddf5.min.js' id='adobe-launch-js'></script>
<script defer src='https://native.sharethrough.com/assets/sfp.js' id='sharethrough-js'></script>
<script defer src='https://ak.sail-horizon.com/spm/spm.v1.min.js' id='nbc-sailthru-js'></script>
<script id='nbc-sailthru-js-after'>
if ("undefined" !== typeof Sailthru) { Sailthru.init({"customerId":"757cc89c051f4552fa5708e6f3b93a01"}); }
</script>
<script defer src='https://js-sec.indexww.com/ht/p/185796-256714881512110.js' id='nbc-index-exchange-js'></script>
<script src='https://www.necn.com/wp-includes/js/wp-embed.min.js?ver=5.8.6' id='wp-embed-js'></script>
<script src='https://stats.wp.com/e-202249.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.9',blog:'165596161',post:'2886628',tz:'-5',srv:'www.necn.com',hp:'vip'} ]);
	_stq.push([ 'clickTrackerInit', '165596161', '2886628' ]);
</script>
	<script>
	(function(b,r,a,n,c,h,_,s,d,k){if(!b[n]||!b[n]._q){for(;s<_.length;)c(h,_[s++]);d=r.createElement(a);d.async=1;d.src="https://cdn.branch.io/branch-latest.min.js";k=r.getElementsByTagName(a)[0];k.parentNode.insertBefore(d,k);b[n]=h}})(window,document,"script","branch",function(b,r){b[r]=function(){b._q.push([r,arguments])}},{_q:[],_v:1},"addListener applyCode autoAppIndex banner closeBanner closeJourney creditHistory credits data deepview deepviewCta first getCode init link logout redeem referrals removeListener sendSMS setBranchViewData setIdentity track validateCode trackCommerceEvent logEvent disableTracking".split(" "), 0);
	branch.init(
		decodeURIComponent('key_live_nf9MZAQExY9iCWCBrPzsTieiqzjjIfsB'),
		{"no_journeys":false}	);
		branch.setBranchViewData({
		data: {
			'$desktop_url': 'https://www.necn.com/news/sports/sports-world-reacts-to-brittney-griners-russian-prison-release/2886628/'
		}
	});
		</script>
	
</body>
</html>
